summaryrefslogtreecommitdiff
path: root/debianutils/Makefile.in
diff options
context:
space:
mode:
authorGlenn L McGrath <bug1@ihug.co.nz>2002-11-11 03:00:12 +0000
committerGlenn L McGrath <bug1@ihug.co.nz>2002-11-11 03:00:12 +0000
commit8f0722a53b9a88c0b4e60b79e4362d0f31c32c54 (patch)
tree2efbea745d3ef22e375df3e60ba4c8f14c04f1c4 /debianutils/Makefile.in
parentc11986d89eba564945b226660031e624bf897561 (diff)
downloadbusybox-w32-8f0722a53b9a88c0b4e60b79e4362d0f31c32c54.tar.gz
busybox-w32-8f0722a53b9a88c0b4e60b79e4362d0f31c32c54.tar.bz2
busybox-w32-8f0722a53b9a88c0b4e60b79e4362d0f31c32c54.zip
Move readlink, mktemp, run-parts and which to a new debianutils dir.
Diffstat (limited to 'debianutils/Makefile.in')
-rw-r--r--debianutils/Makefile.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/debianutils/Makefile.in b/debianutils/Makefile.in
new file mode 100644
index 000000000..91887bda1
--- /dev/null
+++ b/debianutils/Makefile.in
@@ -0,0 +1,36 @@
1# Makefile for busybox
2#
3# Copyright (C) 1999-2002 Erik Andersen <andersee@debian.org>
4#
5# This program is free software; you can redistribute it and/or modify
6# it under the terms of the GNU General Public License as published by
7# the Free Software Foundation; either version 2 of the License, or
8# (at your option) any later version.
9#
10# This program is distributed in the hope that it will be useful,
11# but WITHOUT ANY WARRANTY; without even the implied warranty of
12# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
13# General Public License for more details.
14#
15# You should have received a copy of the GNU General Public License
16# along with this program; if not, write to the Free Software
17# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
18#
19
20DEBIANUTILS_AR:=debianutils.a
21ifndef $(DEBIANUTILS_DIR)
22DEBIANUTILS_DIR:=$(TOPDIR)debianutils/
23endif
24
25
26DEBIANUTILS-y:=
27DEBIANUTILS-$(CONFIG_MKTEMP) += mktemp.o
28DEBIANUTILS-$(CONFIG_READLINK) += readlink.o
29DEBIANUTILS-$(CONFIG_RUN_PARTS) += run_parts.o
30DEBIANUTILS-$(CONFIG_WHICH) += which.o
31
32libraries-y+=$(DEBIANUTILS_DIR)$(DEBIANUTILS_AR)
33
34$(DEBIANUTILS_DIR)$(DEBIANUTILS_AR): $(patsubst %,$(DEBIANUTILS_DIR)%, $(DEBIANUTILS-y))
35 $(AR) -ro $@ $(patsubst %,$(DEBIANUTILS_DIR)%, $(DEBIANUTILS-y))
36