aboutsummaryrefslogtreecommitdiff
path: root/debianutils
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-03-15 08:29:22 +0000
committerEric Andersen <andersen@codepoet.org>2004-03-15 08:29:22 +0000
commitc7bda1ce659294d6e22c06e087f6f265983c7578 (patch)
tree4c6d2217f4d8306c59cf1096f8664e1cfd167213 /debianutils
parent8854004b41065b3d081af7f3df13a100b0c8bfbe (diff)
downloadbusybox-w32-c7bda1ce659294d6e22c06e087f6f265983c7578.tar.gz
busybox-w32-c7bda1ce659294d6e22c06e087f6f265983c7578.tar.bz2
busybox-w32-c7bda1ce659294d6e22c06e087f6f265983c7578.zip
Remove trailing whitespace. Update copyright to include 2004.
Diffstat (limited to 'debianutils')
-rw-r--r--debianutils/Config.in2
-rw-r--r--debianutils/Makefile2
-rw-r--r--debianutils/Makefile.in2
-rw-r--r--debianutils/mktemp.c2
-rw-r--r--debianutils/run_parts.c18
-rw-r--r--debianutils/which.c4
6 files changed, 15 insertions, 15 deletions
diff --git a/debianutils/Config.in b/debianutils/Config.in
index 399ccae6b..7cf7cadb5 100644
--- a/debianutils/Config.in
+++ b/debianutils/Config.in
@@ -33,7 +33,7 @@ config CONFIG_RUN_PARTS
33 It is useful to set up a directory like cron.daily, where you need to 33 It is useful to set up a directory like cron.daily, where you need to
34 execute all the scripts in that directory. 34 execute all the scripts in that directory.
35 35
36 In this implementation of run-parts some features (such as report mode) 36 In this implementation of run-parts some features (such as report mode)
37 are not implemented. 37 are not implemented.
38 38
39 Unless you know that run-parts is used in some of your scripts 39 Unless you know that run-parts is used in some of your scripts
diff --git a/debianutils/Makefile b/debianutils/Makefile
index 13181eadb..0282b83c4 100644
--- a/debianutils/Makefile
+++ b/debianutils/Makefile
@@ -1,6 +1,6 @@
1# Makefile for busybox 1# Makefile for busybox
2# 2#
3# Copyright (C) 1999-2003 by Erik Andersen <andersen@codepoet.org> 3# Copyright (C) 1999-2004 by Erik Andersen <andersen@codepoet.org>
4# 4#
5# This program is free software; you can redistribute it and/or modify 5# This program is free software; you can redistribute it and/or modify
6# it under the terms of the GNU General Public License as published by 6# it under the terms of the GNU General Public License as published by
diff --git a/debianutils/Makefile.in b/debianutils/Makefile.in
index 46530174f..dabef27ef 100644
--- a/debianutils/Makefile.in
+++ b/debianutils/Makefile.in
@@ -1,6 +1,6 @@
1# Makefile for busybox 1# Makefile for busybox
2# 2#
3# Copyright (C) 1999-2003 by Erik Andersen <andersen@codepoet.org> 3# Copyright (C) 1999-2004 by Erik Andersen <andersen@codepoet.org>
4# 4#
5# This program is free software; you can redistribute it and/or modify 5# This program is free software; you can redistribute it and/or modify
6# it under the terms of the GNU General Public License as published by 6# it under the terms of the GNU General Public License as published by
diff --git a/debianutils/mktemp.c b/debianutils/mktemp.c
index ecc985fb2..9fdf79bfa 100644
--- a/debianutils/mktemp.c
+++ b/debianutils/mktemp.c
@@ -40,7 +40,7 @@ extern int mktemp_main(int argc, char **argv)
40 } 40 }
41 else if (opt != 'q') { 41 else if (opt != 'q') {
42 bb_show_usage(); 42 bb_show_usage();
43 } 43 }
44 } 44 }
45 45
46 if (optind + 1 != argc) { 46 if (optind + 1 != argc) {
diff --git a/debianutils/run_parts.c b/debianutils/run_parts.c
index 53d33cec5..6205595bf 100644
--- a/debianutils/run_parts.c
+++ b/debianutils/run_parts.c
@@ -8,7 +8,7 @@
8 * Based on the Debian run-parts program, version 1.15 8 * Based on the Debian run-parts program, version 1.15
9 * Copyright (C) 1996 Jeff Noxon <jeff@router.patch.net>, 9 * Copyright (C) 1996 Jeff Noxon <jeff@router.patch.net>,
10 * Copyright (C) 1996-1999 Guy Maor <maor@debian.org> 10 * Copyright (C) 1996-1999 Guy Maor <maor@debian.org>
11 * 11 *
12 * 12 *
13 * This program is free software; you can redistribute it and/or modify 13 * This program is free software; you can redistribute it and/or modify
14 * it under the terms of the GNU General Public License as published by 14 * it under the terms of the GNU General Public License as published by
@@ -31,21 +31,21 @@
31 * attempt to write a program! :-) . */ 31 * attempt to write a program! :-) . */
32 32
33/* This piece of code is heavily based on the original version of run-parts, 33/* This piece of code is heavily based on the original version of run-parts,
34 * taken from debian-utils. I've only removed the long options and a the 34 * taken from debian-utils. I've only removed the long options and a the
35 * report mode. As the original run-parts support only long options, I've 35 * report mode. As the original run-parts support only long options, I've
36 * broken compatibility because the BusyBox policy doesn't allow them. 36 * broken compatibility because the BusyBox policy doesn't allow them.
37 * The supported options are: 37 * The supported options are:
38 * -t test. Print the name of the files to be executed, without 38 * -t test. Print the name of the files to be executed, without
39 * execute them. 39 * execute them.
40 * -a ARG argument. Pass ARG as an argument the program executed. It can 40 * -a ARG argument. Pass ARG as an argument the program executed. It can
41 * be repeated to pass multiple arguments. 41 * be repeated to pass multiple arguments.
42 * -u MASK umask. Set the umask of the program executed to MASK. */ 42 * -u MASK umask. Set the umask of the program executed to MASK. */
43 43
44/* TODO 44/* TODO
45 * done - convert calls to error in perror... and remove error() 45 * done - convert calls to error in perror... and remove error()
46 * done - convert malloc/realloc to their x... counterparts 46 * done - convert malloc/realloc to their x... counterparts
47 * done - remove catch_sigchld 47 * done - remove catch_sigchld
48 * done - use bb's concat_path_file() 48 * done - use bb's concat_path_file()
49 * done - declare run_parts_main() as extern and any other function as static? 49 * done - declare run_parts_main() as extern and any other function as static?
50 */ 50 */
51 51
@@ -85,7 +85,7 @@ int run_parts_main(int argc, char **argv)
85 /* Set the umask of the programs executed */ 85 /* Set the umask of the programs executed */
86 case 'u': 86 case 'u':
87 /* Check and set the umask of the program executed. As stated in the original 87 /* Check and set the umask of the program executed. As stated in the original
88 * run-parts, the octal conversion in libc is not foolproof; it will take the 88 * run-parts, the octal conversion in libc is not foolproof; it will take the
89 * 8 and 9 digits under some circumstances. We'll just have to live with it. 89 * 8 and 9 digits under some circumstances. We'll just have to live with it.
90 */ 90 */
91 umask(bb_xgetlarg(optarg, 8, 0, 07777)); 91 umask(bb_xgetlarg(optarg, 8, 0, 07777));
diff --git a/debianutils/which.c b/debianutils/which.c
index ccfd16344..999dded36 100644
--- a/debianutils/which.c
+++ b/debianutils/which.c
@@ -2,7 +2,7 @@
2/* 2/*
3 * Which implementation for busybox 3 * Which implementation for busybox
4 * 4 *
5 * Copyright (C) 1999-2003 by Erik Andersen <andersen@codepoet.org> 5 * Copyright (C) 1999-2004 by Erik Andersen <andersen@codepoet.org>
6 * 6 *
7 * This program is free software; you can redistribute it and/or modify 7 * This program is free software; you can redistribute it and/or modify
8 * it under the terms of the GNU General Public License as published by 8 * it under the terms of the GNU General Public License as published by
@@ -53,7 +53,7 @@ extern int which_main(int argc, char **argv)
53 count = 5; 53 count = 5;
54 } 54 }
55 55
56 while (argc-- > 0) { 56 while (argc-- > 0) {
57 char *buf; 57 char *buf;
58 char *path_n; 58 char *path_n;
59 char found = 0; 59 char found = 0;