diff options
author | Glenn L McGrath <bug1@ihug.co.nz> | 2003-11-14 10:04:33 +0000 |
---|---|---|
committer | Glenn L McGrath <bug1@ihug.co.nz> | 2003-11-14 10:04:33 +0000 |
commit | e9080c9f4170b6634f8f8373874e758f48df9127 (patch) | |
tree | b13b328cd2d77a6b5cdbdd05c508f46cf0ed83d9 /debianutils | |
parent | 7b215b99b2c2af4491fdb05058eee1abcc0d37aa (diff) | |
download | busybox-w32-e9080c9f4170b6634f8f8373874e758f48df9127.tar.gz busybox-w32-e9080c9f4170b6634f8f8373874e758f48df9127.tar.bz2 busybox-w32-e9080c9f4170b6634f8f8373874e758f48df9127.zip |
NEW APPLET: pipe_progress, used by debian installer
Diffstat (limited to 'debianutils')
-rw-r--r-- | debianutils/Config.in | 6 | ||||
-rw-r--r-- | debianutils/Makefile.in | 1 | ||||
-rw-r--r-- | debianutils/pipe_progress.c | 54 |
3 files changed, 61 insertions, 0 deletions
diff --git a/debianutils/Config.in b/debianutils/Config.in index 6534cc7e8..399ccae6b 100644 --- a/debianutils/Config.in +++ b/debianutils/Config.in | |||
@@ -11,6 +11,12 @@ config CONFIG_MKTEMP | |||
11 | help | 11 | help |
12 | mktemp is used to create unique temporary files | 12 | mktemp is used to create unique temporary files |
13 | 13 | ||
14 | config CONFIG_PIPE_PROGRESS | ||
15 | bool "pipe_progress" | ||
16 | default n | ||
17 | help | ||
18 | Display a dot to indicate pipe activity. | ||
19 | |||
14 | config CONFIG_READLINK | 20 | config CONFIG_READLINK |
15 | bool "readlink" | 21 | bool "readlink" |
16 | default n | 22 | default n |
diff --git a/debianutils/Makefile.in b/debianutils/Makefile.in index 8ca05c738..46530174f 100644 --- a/debianutils/Makefile.in +++ b/debianutils/Makefile.in | |||
@@ -25,6 +25,7 @@ endif | |||
25 | 25 | ||
26 | DEBIANUTILS-y:= | 26 | DEBIANUTILS-y:= |
27 | DEBIANUTILS-$(CONFIG_MKTEMP) += mktemp.o | 27 | DEBIANUTILS-$(CONFIG_MKTEMP) += mktemp.o |
28 | DEBIANUTILS-$(CONFIG_PIPE_PROGRESS) += pipe_progress.o | ||
28 | DEBIANUTILS-$(CONFIG_READLINK) += readlink.o | 29 | DEBIANUTILS-$(CONFIG_READLINK) += readlink.o |
29 | DEBIANUTILS-$(CONFIG_RUN_PARTS) += run_parts.o | 30 | DEBIANUTILS-$(CONFIG_RUN_PARTS) += run_parts.o |
30 | DEBIANUTILS-$(CONFIG_START_STOP_DAEMON) += start_stop_daemon.o | 31 | DEBIANUTILS-$(CONFIG_START_STOP_DAEMON) += start_stop_daemon.o |
diff --git a/debianutils/pipe_progress.c b/debianutils/pipe_progress.c new file mode 100644 index 000000000..81ce395c9 --- /dev/null +++ b/debianutils/pipe_progress.c | |||
@@ -0,0 +1,54 @@ | |||
1 | /* | ||
2 | * Monitor a pipe with a simple progress display. | ||
3 | * | ||
4 | * Copyright (C) 2003 by Rob Landley <rob@landley.net>, Joey Hess | ||
5 | * | ||
6 | * This program is free software; you can redistribute it and/or modify | ||
7 | * it under the terms of the GNU General Public License as published by | ||
8 | * the Free Software Foundation; either version 2 of the License, or | ||
9 | * (at your option) any later version. | ||
10 | * | ||
11 | * This program is distributed in the hope that it will be useful, | ||
12 | * but WITHOUT ANY WARRANTY; without even the implied warranty of | ||
13 | * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU | ||
14 | * General Public License for more details. | ||
15 | * | ||
16 | * You should have received a copy of the GNU General Public License | ||
17 | * along with this program; if not, write to the Free Software | ||
18 | * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA | ||
19 | * | ||
20 | */ | ||
21 | |||
22 | #include <stdio.h> | ||
23 | #include <unistd.h> | ||
24 | #include <time.h> | ||
25 | |||
26 | #include "busybox.h" | ||
27 | |||
28 | #define PIPE_PROGRESS_SIZE 4096 | ||
29 | |||
30 | /* Read a block of data from stdin, write it to stdout. | ||
31 | * Activity is indicated by a '.' to stderr | ||
32 | */ | ||
33 | extern int pipe_progress_main(int argc, char **argv) | ||
34 | { | ||
35 | RESERVE_CONFIG_BUFFER(buf, PIPE_PROGRESS_SIZE); | ||
36 | time_t t = time(NULL); | ||
37 | size_t len; | ||
38 | |||
39 | while ((len = fread(buf, 1, PIPE_PROGRESS_SIZE, stdin)) > 0) { | ||
40 | time_t new_time = time(NULL); | ||
41 | if (new_time != t) { | ||
42 | t = new_time; | ||
43 | fputc('.', stderr); | ||
44 | } | ||
45 | fwrite(buf, len, 1, stdout); | ||
46 | } | ||
47 | |||
48 | fputc('\n', stderr); | ||
49 | |||
50 | #ifdef CONFIG_FEATURE_CLEAN_UP | ||
51 | RELEASE_CONFIG_BUFFER(buf); | ||
52 | #endif | ||
53 | return 0; | ||
54 | } | ||