aboutsummaryrefslogtreecommitdiff
path: root/include/platform.h (follow)
Commit message (Collapse)AuthorAgeFilesLines
...
* add -Wundef, fix uncovered bugsDenis Vlasenko2006-11-171-1/+1
|
* whitespace cleanupDenis Vlasenko2006-09-171-2/+2
|
* Revert duplicate patch.Rob Landley2006-09-121-8/+0
| | | | | | | | | | | | I don't know why patch decided to apply this even though it was already in the tree. I thought the other hunks failed because they were totally unrelated leakage from Bernhard's tree (which they are; was the a reason for bundling them in with this fix? Do they have something to do with the GCC 2.95 fix? I suspect they prevent me from backporting this patch to 1.2.2 because the header consolidation into libbb.h hadn't been done yet, and no I'm not fixing it up: if that's the case then this patch won't be in 1.2.2 due to extraneous changes bundled with it that prevent a clean backport without rolling a new patch).
* Fix from Bernhard for somebody trying to limp along with gcc 2.95.4.Rob Landley2006-09-121-0/+8
|
* - small trivia to be gentle to gcc-2.95.x which had no va_copy but only ↵Bernhard Reutner-Fischer2006-09-121-0/+8
| | | | __va_copy.
* Ok, features.h already defines _OPEN_SOURCE (and complains if it's alreadyRob Landley2006-08-101-1/+0
| | | | | defined), yet it's not doing it for scripts/individual for some reason. (I hate fighting with header files.)
* Another whack at scripts/individual. Now builds 212 applets.Rob Landley2006-08-091-0/+1
|
* Add shared subtree support, suggested by Vladimir Dronnikov. Also break out aRob Landley2006-08-081-0/+29
| | | | | | few new (unfinished) config options, which I intend to make hidden (but enabled) when CONFIG_NITPICK is disabled. Getting the .config infrastructure to do that is non-obvious, it seems...
* move lchown/chown define out of specific files and into platform.h where it ↵Mike Frysinger2006-07-201-1/+7
| | | | belongs
* Some old kernel headers don't #include BLKSSZGET in sys/mount.h.Rob Landley2006-06-291-0/+3
|
* Patch from Shaun Jackman to replace CFLAGS_EXTRA with .config.makRob Landley2006-06-221-1/+1
|
* We came up with our own names for ATTRIBUTE_*, so why check if they're alreadyRob Landley2006-06-151-22/+0
| | | | | #defined? Also remove a check for a gcc version older than RH9 (if non-linux needs that #define they can put it in their section.)
* Patch from Yann Morin to put BLKGETSIZE64 in platform.h had rather a lot ofRob Landley2006-06-151-1/+4
| | | | | | fallout due to the #include <sys/mount.h>. Removed that #include from various applets and fixed up those that were unhappy when that #include was made because they'd block copied stuff out of it. (Sigh.)
* Random cleanup of platform.h.Rob Landley2006-06-131-16/+24
|
* only check __GNU_LIBRARY__ if it is actually definedMike Frysinger2006-06-061-2/+2
|
* Shaun Jackman pointed out that KERNEL_VERSION() is used without guards, soRob Landley2006-06-011-2/+0
| | | | defining it in a guard is silly.
* - conditionally define BB_NOMMUBernhard Reutner-Fischer2006-05-311-4/+14
|
* Put parentheses around some of the SWAP() macros, as pointed out by PeterRob Landley2006-05-301-6/+6
| | | | Kjellerstedt.
* Add SWAP_LE?? and SWAP_BE?? macros, and make things use them. Converts valuesRob Landley2006-05-291-5/+16
| | | | | to/from little endian or big endian, which is a NOP if that's what the current platform already is.
* Remove _() and N_() from platform.h. #define them as NOP macros in the twoRob Landley2006-05-291-12/+4
| | | | | | files still using them. I didn't remove them from e2fsck.c to avoid stomping pending cleanup patches from Garrett, and I didn't bother to remove them from fdisk.c because that entire file needs to be rewritten from scratch.
* Move portability stuff to platform.h, and clean up adjtimex.c a bit whileRob Landley2006-05-271-0/+17
| | | | I'm in the area.
* - add workaround for tar being broken since it uses a non-portable constant.Bernhard Reutner-Fischer2006-05-261-0/+6
|
* - move libc checks from busybox.h to platform.hBernhard Reutner-Fischer2006-05-261-4/+101
| | | | | | | - add ATTRIBUTE_ALWAYS_INLINE, endian handling for DEC UNIX, some more compiler dependent defines to platform.h - add conditional bb_setpgrp define to platform.h - remove superfluous specifying args from "#define fdprintf dprintf"
* New version of nohup that's much smaller, less paranoid, consistent,Rob Landley2006-05-211-0/+2
| | | | vaguely portable, and licensed GPLv2 "or later".
* - backout erroneously checked in snippet..Bernhard Reutner-Fischer2006-05-191-2/+0
|
* - remove emacs layout block as suggested by Robert P.J. DayBernhard Reutner-Fischer2006-05-191-0/+3
| | | | - use shorter boilerplate while at it
* - single KERNEL_VERSION(a,b,c) macro in platform.hBernhard Reutner-Fischer2006-05-191-0/+7
| | | | | - rename get_kernel_revision() to get_linux_version_code from Robert P. J. Day
* Remove bb_strlen() in favor of -fno-builtin-strlen. Saves as many bytesRob Landley2006-05-071-5/+0
| | | | | as the old optimization did (actually does slightly better under gcc 4.0), and simplifies the code.
* Not quite compiler independent, but we've never tried to be gcc independentRob Landley2006-05-041-11/+5
| | | | | anyway. This is at least less ugly than what was there before, and fixes building all sources at once.
* just whitespace fixesMike Frysinger2006-03-281-16/+16
|
* Define both big endian and little endian macros.Rob Landley2006-03-251-3/+6
|
* fix typoMike Frysinger2006-03-231-1/+1
|
* Fixup to the previous (portability) patch. Linux actually does needRob Landley2006-03-091-0/+8
| | | | arpa/inet.h rather than netinet/in.h, otherwise we get warnings.
* - put NLS stuff in one central place to avoid redefines.Bernhard Reutner-Fischer2006-02-231-1/+5
| | | | | | | | Fixes warnings about: fdisk.c:45:1: warning: "_" redefined nfsmount.c:121:1: warning: "_" redefined nfsmount.c:122:1: warning: "N_" redefined interface.c:84:1: warning: "_" redefined
* Patch from Devin Bayer to split up hash_fd.c into md5.c and sha1.c. (I tweakedRob Landley2006-02-211-0/+15
| | | | md5_sha1_sum.c to convert some #ifdef CONFIG to if(ENABLE).)
* New USE() macrosRob Landley2006-02-131-5/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | For each CONFIG_SYMBOL, include/bb_config.h now has both ENABLE_SYMBOL and USE_SYMBOL(x). ENABLE_SYMBOL is still always defined (1 or 0) so that if(ENABLE) should optimize out when it's zero. The USE_SYMBOL(X) will only splice in X if the symbol is defined, otherwise it'll be empty. Thus we can convert this: #ifdef CONFIG_ARGS opt = bb_getopt_ulflags(argc, argv, "ab:c" #ifdef CONFIG_THINGY "d:" #endif , &bvalue #ifdef CONFIG_THINGY , &thingy #endif ); #endif into this: if (ENABLE_ARGS) { opt = bb_getopt_ulflags(argc, argv, "ab:c" USE_THINGY("d:"), &bvalue USE_THINGY(, &thingy)); } And it should produce the same code. Unlike the old versions in include/_usage.h, the new USE_SYMBOL(x) can handle commas in its arguments (as shown above). (The _usage.h file is obsolete and no longer generated.) Nobody should need to include config.h directly anymore, bb_config.h should define all the configuration stuff we need. Someday, the CONFIG_SYMBOL versions should go away in favor of ENABLE_SYMBOL and USE_SYMBOL(). Thanks to vodz for the new version of bb_mkdep.c that works with function macros.
* - add and use ATTRIBUTE_ALIGNED(num_bytes)Bernhard Reutner-Fischer2006-01-311-0/+4
| | | | - remove unused parameter pindex from fdisk.c, xbsd_initlabel()
* - add platform.h.Bernhard Reutner-Fischer2006-01-221-0/+82
- use shorter boilerplate while at it.