summaryrefslogtreecommitdiff
path: root/miscutils (follow)
Commit message (Collapse)AuthorAgeFilesLines
...
* use vfork() instead of vork() since the only thing we do is execve() an app ↵Mike Frysinger2006-06-061-1/+1
| | | | after fork (allows time to work on no-mmu)
* - remove superfluous call of stack_machine(0) upon exit.Bernhard Reutner-Fischer2006-06-031-1/+0
|
* - no need to have timer_duration in the data section.Bernhard Reutner-Fischer2006-06-031-7/+4
| | | | - cleanup a little bit while at it.
* - use bb_msg_write_error in 3 placesBernhard Reutner-Fischer2006-06-031-368/+346
| | | | - whitespace
* - move #include busybox.h to the very top so we pull in the configBernhard Reutner-Fischer2006-06-0317-24/+22
| | | | and eventual platform specific includes in early.
* Patch from Tito to remove long options from hdparm.Rob Landley2006-05-312-25/+11
|
* - s/defined(__uClinux__)/BB_NOMMU/Bernhard Reutner-Fischer2006-05-311-3/+3
| | | | | | | This needs a second pass to: + add bb_daemon(unsigned char no_chdir, unsigned char no_close, const char*flag) + eventually globally export argc and argv, so we don't need to pass it to bb_daemon().
* Size reductions, mostly switching things to use libbb functions.Rob Landley2006-05-291-1/+1
|
* Add SWAP_LE?? and SWAP_BE?? macros, and make things use them. Converts valuesRob Landley2006-05-291-7/+5
| | | | | to/from little endian or big endian, which is a NOP if that's what the current platform already is.
* Fix hdparm to use PRIu64 instead of typecasting to long long (which is 128 bitsRob Landley2006-05-281-4/+4
| | | | on 64 bit platforms), and move #include <inttypes.h> to libbb.h.
* Move portability stuff to platform.h, and clean up adjtimex.c a bit whileRob Landley2006-05-271-58/+3
| | | | I'm in the area.
* Consolidate #include <sys/time.h> so libbb.h does it.Rob Landley2006-05-274-4/+0
|
* - use the defines CURRENT_TTY and VC_1; also shrink xargs a tiny bit:Bernhard Reutner-Fischer2006-05-271-1/+1
| | | | | | | | | | | | | | | | add/remove: 0/0 grow/shrink: 2/6 up/down: 5/-37 (-32) function old new delta static.add_interface 271 274 +3 static.glob3 36 38 +2 static.renice_main 409 408 -1 static.readcmd 1083 1081 -2 static.changepath 176 174 -2 static.parse_opts 56 51 -5 static.rx_main 1095 1088 -7 static.xargs_main 759 739 -20 ---------------------------------------------------------------- Result :-) -32
* - provide fallback defines for non-linuxBernhard Reutner-Fischer2006-05-261-0/+14
|
* - add central knob to turn off getopt_long everywhere. EXPERIMENTAL!Bernhard Reutner-Fischer2006-05-261-1/+1
| | | | | | Adds "Enable getopt long" under "General options", default y. Send patches to fix getopt_ulflags and run_parts.c if you turn this off.. See http://busybox.net/lists/busybox/2006-May/021828.html for a start to run-parts
* - introduce and use bb_path_wtmp_file for portability (saves 11 Bytes).Bernhard Reutner-Fischer2006-05-261-2/+6
| | | | - fix last.c to also look at the double-underscore UT_ defines.
* Yann E. MORIN. writes:Mike Frysinger2006-05-261-1/+1
| | | | | | hdparm has a uint64_t passed to printf with a %llu format (which is ok, because it's the same size), but without first being casted(?) to unsigned long long int. Which is kinda funny because it's done OK on a few lines above...
* And fix the error I just introduced. :)Rob Landley2006-05-251-1/+1
|
* Remove pointless #define.Rob Landley2006-05-251-4/+1
|
* Patch from Tito:Rob Landley2006-05-251-168/+123
| | | | | | | | | | | | | | | | | | | Remove -v verbose -V version -q quiet flags Remove parse_opt_v2(); Rename parse_opt_v3() to parse_xfermode() Remove if_strcat() Rearrange code in  dump_identity() to reduce size Modify some strings so that they could be optimized by the compiler Minor code clean up Remove unneeded #define <shm.h> #if BB_BIG_ENDIAN && !defined(__USE_XOPEN) # define __USE_XOPEN #endif     Must be before #include <unistd.h> and #include "busybox.h" (noticed by Bernhard Fischer <rep.nop@aon.at>) Remove duplicate code in do_time()
* New version of nohup that's much smaller, less paranoid, consistent,Rob Landley2006-05-211-15/+0
| | | | vaguely portable, and licensed GPLv2 "or later".
* - silence warning about no return in function returning non-voidBernhard Reutner-Fischer2006-05-202-25/+29
| | | | | - put CONFIG_DEBUG_CROND_OPTION into config no changes in size when debugging is disabled.
* - remove emacs layout block as suggested by Robert P.J. DayBernhard Reutner-Fischer2006-05-191-8/+0
| | | | - use shorter boilerplate while at it
* Patch from tito to replace shared memory usage with mlock(), slightly tweakedRob Landley2006-05-191-24/+10
| | | | by me.
* - fix invalid modeBernhard Reutner-Fischer2006-05-191-1/+1
|
* Largeish cleanup patch from Tito, mostly if statement therapy.Rob Landley2006-05-161-534/+350
|
* pull Rules.mak from top_srcdir as pointed out by Robert P. J. Day on the ↵Mike Frysinger2006-05-131-1/+1
| | | | mailing list
* typecast bbig to kill format warningsMike Frysinger2006-05-111-3/+3
|
* The if() is cheaper than the extra function parameter. According to makeRob Landley2006-05-081-26/+26
| | | | bloatcheck, this saves 112 bytes on x86...
* Cleanup patch from tito.Rob Landley2006-05-071-379/+158
|
* Patch from Dennis Vlasenko resetting values that get reused.Rob Landley2006-05-051-5/+18
|
* Remove HDIO_GETGEO_BIG which is dead (removed from 2.6) and was pointless backRob Landley2006-05-031-12/+4
| | | | | | | | | in 2.4 (it fetched the same hd_geometry struct only with uint cylinders instead of ushort cylinders: nothing that big has ever accurately reported gemoetry, it's all LBA. Also stop declaring the hd_geometry struct static: it's two chars, a short, and a long for a grand total of 8 bytes. That can go on the stack.
* Use ATTRIBUTE_NORETURN as suggested by tito, plus a few in-passing cleanups.Rob Landley2006-05-031-16/+13
|
* Patch from tito removing obsolete code.Rob Landley2006-05-011-142/+11
|
* Remove some unused code pointed out by Tito, plus a slightly more gracefulRob Landley2006-04-291-35/+7
| | | | way of handling endianness.
* Style fixes from Denis Vlasenko.Rob Landley2006-04-291-147/+146
|
* Another patch from Denis Vlasenko:Rob Landley2006-04-291-48/+42
| | | | | | | | | Make hdparm smaller: * Make bb_ioctl return the status * Replace ioctl with bb_ioctl in a few places * Add bb_ioctl_alt, use where appropriate (four places) * unsigned char args1[4+512] = {WIN_IDENTIFY,0,0,1,}; ate 0.5k of rodata, fix that
* From Dennis Vlasenko, Make hdparm smaller:Rob Landley2006-04-291-73/+49
| | | | | * Use combined no_scsi_no_xt() * Have common unsigned char args[4] = {WIN_SETFEATURES,0,0,0};
* Cleanup to hdparm by tito.Rob Landley2006-04-291-12/+11
|
* just include fcntl.h not sys/fcntl.hMike Frysinger2006-04-291-1/+1
|
* Rob Sullivan writes: rewrite the regex handling to improve stabilityMike Frysinger2006-04-291-58/+51
|
* Patch from tito to update output of hdparm.Rob Landley2006-04-281-12/+22
|
* - return ret so we return something meaningful.Bernhard Reutner-Fischer2006-04-241-1/+1
|
* From Rob Sullivan: Fix a segfault with searching, plus some cleanups.Rob Landley2006-04-181-58/+49
|
* Patch from Tito to fix printing null and make output look like hdparm 6.3.Rob Landley2006-04-171-5/+5
|
* just use the stack to kill memleak and return if user didnt give us anything ↵Mike Frysinger2006-04-161-7/+5
| | | | to match
* use xmalloc, dont hardcode length of string, and get rid of pointless call ↵Mike Frysinger2006-04-161-3/+2
| | | | to memset
* uncuddle if statementsMike Frysinger2006-04-161-5/+5
|
* use more boiler plate GPL noticesMike Frysinger2006-04-167-40/+11
|
* uncuddle bracketsMike Frysinger2006-04-161-69/+78
|