aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTimothy Gu <timothygu99@gmail.com>2014-09-13 17:01:43 -0700
committerTimothy Gu <timothygu99@gmail.com>2014-09-13 17:03:07 -0700
commit2d6c00722652589b6c2532d9e9a43417d29612c1 (patch)
tree04bd767f7fb6de394a21d60d5d487ac41b5af2a3 /configure.ac
parentcf56306383935c6123f1ab70fcb73c850e301819 (diff)
downloaddlfcn-win32-2d6c00722652589b6c2532d9e9a43417d29612c1.tar.gz
dlfcn-win32-2d6c00722652589b6c2532d9e9a43417d29612c1.tar.bz2
dlfcn-win32-2d6c00722652589b6c2532d9e9a43417d29612c1.zip
Add autotools build system
Signed-off-by: Timothy Gu <timothygu99@gmail.com>
Diffstat (limited to '')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c9596bd
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,31 @@
1AC_PREREQ(2.59)
2
3AC_INIT([dlfcn-win32], [1.0.0.99], [timothygu99@gmail.com])
4
5AC_CONFIG_MACRO_DIR([m4])
6
7AC_CANONICAL_BUILD
8
9AM_INIT_AUTOMAKE([foreign])
10LT_INIT
11
12AC_PROG_CC
13
14AC_MSG_CHECKING([windows.h and win32 API])
15AC_LINK_IFELSE([
16 AC_LANG_PROGRAM([[
17 #include <windows.h>
18 ]], [[
19 LoadLibrary(NULL);
20 ]])
21], [
22 AC_MSG_RESULT([yes])
23], [
24 AC_MSG_RESULT([no])
25 AC_MSG_ERROR([C compiler is not able to link standard win32 program.])
26])
27
28MINGW_AC_MSVC_IMPORT_LIBS([LIBDL_MSVC_LIB], [libdl.lib])
29
30AC_CONFIG_FILES(Makefile)
31AC_OUTPUT \ No newline at end of file