aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index cd321f2..e9b3e85 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -7,19 +7,19 @@ if(WIN32)
7 7
8 add_library(testdll2 SHARED testdll2.c) 8 add_library(testdll2 SHARED testdll2.c)
9 set_target_properties(testdll2 PROPERTIES PREFIX "") 9 set_target_properties(testdll2 PROPERTIES PREFIX "")
10 target_link_libraries(testdll2 dl) 10 target_link_libraries(testdll2 dlfcn-win32::dl)
11 11
12 add_library(testdll3 SHARED testdll3.c) 12 add_library(testdll3 SHARED testdll3.c)
13 set_target_properties(testdll3 PROPERTIES PREFIX "") 13 set_target_properties(testdll3 PROPERTIES PREFIX "")
14 14
15 add_executable(t_dlfcn test.c) 15 add_executable(t_dlfcn test.c)
16 target_link_libraries(t_dlfcn dl) 16 target_link_libraries(t_dlfcn dlfcn-win32::dl)
17 17
18 add_test(NAME t_dlfcn COMMAND t_dlfcn WORKING_DIRECTORY $<TARGET_FILE_DIR:t_dlfcn> ) 18 add_test(NAME t_dlfcn COMMAND t_dlfcn WORKING_DIRECTORY $<TARGET_FILE_DIR:t_dlfcn> )
19endif() 19endif()
20 20
21add_executable(test-dladdr test-dladdr.c) 21add_executable(test-dladdr test-dladdr.c)
22target_link_libraries(test-dladdr dl) 22target_link_libraries(test-dladdr dlfcn-win32::dl)
23if(UNIX) 23if(UNIX)
24 set_target_properties(test-dladdr PROPERTIES COMPILE_FLAGS "-Wl,--export-dynamic -fpie") 24 set_target_properties(test-dladdr PROPERTIES COMPILE_FLAGS "-Wl,--export-dynamic -fpie")
25endif() 25endif()