summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
...
* new API function to force garbage collection.Roberto Ierusalimschy1997-05-263-8/+18
|
* unused declaration.Roberto Ierusalimschy1997-05-261-2/+1
|
* another (better?) implementation for "pushsubscript".Roberto Ierusalimschy1997-05-261-10/+16
|
* new implementation of gc: "Pre-collect" garbage in temporary lists andRoberto Ierusalimschy1997-05-147-87/+121
| | | | then call fallbacks.
* double hashing + tables do not grow if there are empty slotsRoberto Ierusalimschy1997-05-081-83/+94
|
* bug: string table must be initialized.Roberto Ierusalimschy1997-05-051-3/+15
|
* correction of name (and "iternal" was wrong, any way).Roberto Ierusalimschy1997-04-301-1/+1
|
* small optimization in the access to i.m. table.Roberto Ierusalimschy1997-04-243-40/+49
|
* BUG: input file must be closed just after parser.Roberto Ierusalimschy1997-04-152-20/+15
|
* missing definition of "lua_storesubscript", for compatibilityRoberto Ierusalimschy1997-04-151-3/+5
|
* new pragma "$endinput"Roberto Ierusalimschy1997-04-141-4/+7
|
* global variables (in $if) may have '_'.Roberto Ierusalimschy1997-04-141-3/+3
|
* function name is only needed *if* there is an error.Roberto Ierusalimschy1997-04-141-5/+5
|
* mem.h is now luamem.hv3.0-alphaLuiz Henrique de Figueiredo1997-04-141-23/+23
| | | | | | removed warn added support for new opcodes (VARARGS, STOREMAP) better error messages with luaL_verror
* fix comment in VERSIONLuiz Henrique de Figueiredo1997-04-141-2/+2
|
* nested "$if's", "$else", and "$if" constants (nil & 1).Roberto Ierusalimschy1997-04-121-39/+103
|
* correction on comments about opcodes.Roberto Ierusalimschy1997-04-111-14/+14
|
* one cannot "create" a userdata.Roberto Ierusalimschy1997-04-081-2/+2
|
* first implementation of "$if";Roberto Ierusalimschy1997-04-076-73/+139
| | | | new function "findstring" (useful in good places)
* detail: local namesRoberto Ierusalimschy1997-04-061-5/+5
|
* detail: better way to put a "..." in message.Roberto Ierusalimschy1997-04-061-3/+3
|
* luaL check functions do not need the function name (it can beRoberto Ierusalimschy1997-04-0610-125/+129
| | | | accessed via luadebug interface).
* better error messages;Roberto Ierusalimschy1997-04-0410-100/+107
| | | | better names for some API functions.
* using new lib auxlib.Roberto Ierusalimschy1997-04-042-30/+18
|
* "setintmethod" returns old method (to be coerent with seterrormethod).Roberto Ierusalimschy1997-04-031-5/+5
| | | | | BUG: wrong pointer arithmetic (index out of range when comparing). obs: version 4 is due to internal methods.
* obs: version 4 is due to internal methods.Roberto Ierusalimschy1997-04-031-4/+4
| | | | (some small details in comments)
* "setintmethod" returns old method (to be coerent with seterrormethod).Roberto Ierusalimschy1997-04-031-1/+2
| | | | obs: version 2 is due to internal methods.
* new function "getintmethod"Roberto Ierusalimschy1997-04-026-10/+30
|
* "tostring" gives an overview of a userdata.Roberto Ierusalimschy1997-04-021-12/+37
|
* "newtag" does not need a type name.Roberto Ierusalimschy1997-04-024-49/+25
|
* lua_getuserdata must return NULL if object is not userdataRoberto Ierusalimschy1997-04-021-4/+4
|
* lua_getuserdata must return NULL if object is not userdata;Roberto Ierusalimschy1997-04-021-4/+12
| | | | small BUG: wrong error message for a=b[1] (b not a table)
* "getbyte" returns userdata size when called without second parameter.Roberto Ierusalimschy1997-04-021-6/+10
|
* small "bugs" detected by Purify: cannot read "next" after 0.Roberto Ierusalimschy1997-04-011-4/+6
|
* small "bugs" detected by Purify: some blocks may be smaller thanRoberto Ierusalimschy1997-04-011-2/+2
| | | | sizeof(int).
* "storeglobal" changed to "setglobal"Roberto Ierusalimschy1997-04-013-14/+15
|
* new lua function "tag"Roberto Ierusalimschy1997-04-011-1/+7
|
* first version of "setglobal" and "getglobal" internal methods.Roberto Ierusalimschy1997-03-316-82/+115
|
* some new options for warnings and optimizations.Roberto Ierusalimschy1997-03-311-2/+3
|
* update of ".h" dependenciesRoberto Ierusalimschy1997-03-311-15/+15
|
* new name for old "mem.h" (conflicts with some compiler libraries)Roberto Ierusalimschy1997-03-3112-35/+35
|
* "Object" renamed to "TObject" (Tagged Object), to avoid conflicts withRoberto Ierusalimschy1997-03-3110-117/+117
| | | | pre-defined names in some C compilers.
* new (internal?) functions to manipulate userdataRoberto Ierusalimschy1997-03-263-26/+72
|
* BUG: must mark userdata in garbage collection.Roberto Ierusalimschy1997-03-261-2/+3
|
* some corrections, improvements;Roberto Ierusalimschy1997-03-242-20/+22
|
* must call "gc" i.m. for nil after all others.Roberto Ierusalimschy1997-03-212-4/+10
|
* mathlib now uses i.m. for "pow" operator.Roberto Ierusalimschy1997-03-212-23/+7
|
* files now have proper tags.Roberto Ierusalimschy1997-03-201-5/+8
|
* BUG: lua_newtag can be called before luaI_IMtable is initialized.Roberto Ierusalimschy1997-03-201-8/+12
|
* i.m. "arith" and "order" splited for different operationsRoberto Ierusalimschy1997-03-204-122/+151
|