summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
...
* comments about use of 'luaH_set'Roberto Ierusalimschy2011-08-152-2/+6
|
* new implementation for 'getobjname': first search for relevantRoberto Ierusalimschy2011-08-121-85/+87
| | | | | instruction (new function 'findsetreg') and then try to build a meaningful name
* commentRoberto Ierusalimschy2011-08-111-2/+2
|
* no more 'luaH_setstr (used only once) + 'luaH_setint' receives valueRoberto Ierusalimschy2011-08-097-34/+25
| | | | to be set.
* 'string.format' checks whether values for integer formats areRoberto Ierusalimschy2011-08-091-5/+14
| | | | actually integers
* detail (using array instead of several variables to keep track ofRoberto Ierusalimschy2011-08-041-10/+17
| | | | enabled command-line options)
* better error message when trying to open filesRoberto Ierusalimschy2011-08-021-6/+4
|
* detail: factoring in common code for opening files and checking forRoberto Ierusalimschy2011-07-281-16/+14
| | | | errors
* reducing even more use of C stack by the parser: struct 'FuncState'Roberto Ierusalimschy2011-07-272-19/+18
| | | | | does not need field 'L' + number of labels/gotos in a chunk may be limited to SHRT_MAX. (Also removed some non-needed 'unsigned's.)
* no more field 'L' in 'FuncState'Roberto Ierusalimschy2011-07-271-7/+7
|
* tonumber: base 10 is not special, no base isRoberto Ierusalimschy2011-07-271-8/+10
|
* refuse things like 'inf' or 'Nan' as numeralsRoberto Ierusalimschy2011-07-271-4/+6
|
* 'M_IX86' -> '_M_IX86'Roberto Ierusalimschy2011-07-251-2/+2
|
* removed unused variable 'found' (in 'findfield') + removed legacyRoberto Ierusalimschy2011-07-251-4/+3
| | | | test for 'what' being "tail"
* detail (cleaned whitespaces at end of lines)Roberto Ierusalimschy2011-07-154-10/+10
|
* no more 'zungetc' (better not to read next char)Roberto Ierusalimschy2011-07-152-22/+20
|
* macro 'char2int' replaced by 'cast_uchar' (used by other files)Roberto Ierusalimschy2011-07-152-6/+4
|
* better code for numerical escapesRoberto Ierusalimschy2011-07-151-28/+19
|
* added '_M_IX86' in NaN trickv5.2-betaRoberto Ierusalimschy2011-07-081-7/+5
|
* detailRoberto Ierusalimschy2011-07-081-4/+4
|
* error on invalid escape sequencesRoberto Ierusalimschy2011-07-081-31/+38
|
* detail (comment)Roberto Ierusalimschy2011-07-061-2/+2
|
* '\*' -> '\z' + '\?' is not an official escape sequenceRoberto Ierusalimschy2011-07-051-3/+3
|
* removed and deprecated functions really removed from the code baseRoberto Ierusalimschy2011-07-054-46/+17
|
* NILCONSTANT also depends no endianess (with NaN trick)Roberto Ierusalimschy2011-07-041-4/+4
|
* comments about some compiler options that should be tested once in a whileRoberto Ierusalimschy2011-07-041-2/+3
|
* 'table.pack' also returns 'n' + 'deprecated' changed to 'removed'Roberto Ierusalimschy2011-07-021-15/+17
|
* reordering of some defines (more logical grouping)Roberto Ierusalimschy2011-07-021-2/+2
|
* compilation warning about integer size x pointer sizeRoberto Ierusalimschy2011-07-021-2/+2
|
* small simplifications (and assert was wrongly written)Roberto Ierusalimschy2011-07-021-4/+2
|
* simpler 'luai_apicheck' (and avoids compilation error...)Roberto Ierusalimschy2011-07-021-3/+7
|
* 'deprecated' x 'removed' (they are not the same thing)Roberto Ierusalimschy2011-07-021-6/+6
|
* 'package.loaders' -> 'package.searchers'Roberto Ierusalimschy2011-06-282-25/+35
|
* no more errors on accesses to 'string' and stringsRoberto Ierusalimschy2011-06-281-19/+7
|
* back to internal table for 'ctype', no more locale manipulationRoberto Ierusalimschy2011-06-281-23/+4
|
* use standard "underscore + uppercases" for reserved keys in the registryRoberto Ierusalimschy2011-06-271-2/+2
|
* commentsRoberto Ierusalimschy2011-06-271-1/+2
|
* avoid "magic constant" 32 (the difference from 'A' to 'a')Roberto Ierusalimschy2011-06-271-2/+2
|
* back to "one-label-per-block"Roberto Ierusalimschy2011-06-271-20/+13
|
* useless assignments removed (macros already do the assignment)Roberto Ierusalimschy2011-06-241-4/+4
|
* resort to standard C ctype for non-ASCII systems + 'ltoupper' replacedRoberto Ierusalimschy2011-06-241-6/+41
| | | | by 'ltolower'
* resort to standard C ctype for non-ASCII systemsRoberto Ierusalimschy2011-06-241-3/+7
|
* using 'tolower' instead of 'toupper' (slightly simpler to implement)Roberto Ierusalimschy2011-06-241-2/+2
|
* macro 'ltoupper' instead of 'lisupper' (more usefull for Lua)Roberto Ierusalimschy2011-06-233-24/+33
|
* label syntax changed to '::label::'Roberto Ierusalimschy2011-06-231-2/+7
|
* change in the representation of file handlesRoberto Ierusalimschy2011-06-211-139/+128
|
* label syntax changed to '::label::'Roberto Ierusalimschy2011-06-202-8/+8
|
* commentRoberto Ierusalimschy2011-06-201-2/+2
|
* added cast to void to calls to 'setlocale' (to easy redefining it asRoberto Ierusalimschy2011-06-201-3/+3
| | | | a constant)
* typo in messageRoberto Ierusalimschy2011-06-201-2/+2
|