summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* format "%s" in 'string.format' accepts embedded zeros when itv5.3.2Roberto Ierusalimschy2015-11-251-9/+12
| | | | has no modifiers
* randomness in 'table.sort' used only when needed (big imbalance inRoberto Ierusalimschy2015-11-251-38/+73
| | | | partition result) + small refactoring
* handling 'clock_t' and 'time_t' correctly in ISO C point of viewRoberto Ierusalimschy2015-11-241-5/+14
|
* easy the way to accept other modifiers for 'mode' in 'io.open'Roberto Ierusalimschy2015-11-231-7/+13
|
* tiny code refactoring in 'luaS_hash'Roberto Ierusalimschy2015-11-231-4/+3
|
* ensure argument to 'string.format("%s")' does not contain zerosRoberto Ierusalimschy2015-11-231-1/+2
|
* details (comments)Roberto Ierusalimschy2015-11-235-11/+11
|
* using unsigned int (instead of int) in 'table.sort' to avoid overflowsRoberto Ierusalimschy2015-11-231-17/+23
| | | | (when computing the pivot and in original table size)
* details (merging declarations with initialization)Roberto Ierusalimschy2015-11-231-7/+5
|
* randomness in pivot for 'table.sort' done by a macro (easier to change)Roberto Ierusalimschy2015-11-201-11/+17
|
* details (typos in comments)Roberto Ierusalimschy2015-11-1910-22/+22
|
* detailRoberto Ierusalimschy2015-11-171-2/+2
|
* detailsRoberto Ierusalimschy2015-11-131-18/+18
|
* added separator for bugs in 5.3.1Roberto Ierusalimschy2015-11-131-0/+4
|
* new release number (5.3.2)Roberto Ierusalimschy2015-11-131-2/+2
|
* trying to optimize a little 'luaD_poscall'Roberto Ierusalimschy2015-11-133-25/+56
|
* removed field 'n' from 'CallInfo' (not being used right now)Roberto Ierusalimschy2015-11-132-16/+12
|
* macro with empty argument can be seen as macro with no argument; betterRoberto Ierusalimschy2015-11-121-3/+3
| | | | to avoid that
* in 'table.sort': tighter checks for invalid order function +Roberto Ierusalimschy2015-11-121-5/+22
| | | | | "random" pivot for larger intervals (to avoid attacks with bad data)
* avoid the use of deprecated functions 'luaL_checkunsigned'/Roberto Ierusalimschy2015-11-111-21/+25
| | | | 'lua_pushunsigned'
* janitor work on 'table.sort': added comments, partition code movedRoberto Ierusalimschy2015-11-061-54/+76
| | | | | to a separated function, code conventions updated, etc. No changes at all in the logic/algorithm
* no need for a special case to get long strings (not that common)Roberto Ierusalimschy2015-11-031-22/+16
|
* allow 'set' macros to be used when 'L' is not available (as it wasRoberto Ierusalimschy2015-11-031-2/+2
| | | | needed only for assertions)
* added comment and assert about dead keysRoberto Ierusalimschy2015-11-032-5/+11
|
* bug: despite its name, 'luaH_getstr' did not work for strings inRoberto Ierusalimschy2015-11-033-20/+44
| | | | general, but only for short strings
* new function 'luaS_hashlongstr'Roberto Ierusalimschy2015-11-032-2/+13
|
* in 'luaD_call', use two functions instead of one with fixed booleanRoberto Ierusalimschy2015-11-021-10/+29
| | | | | argument + stack error handling in 'luaD_call' moved to a separated function
* in 'luaD_call', use two functions instead of one with fixed booleanRoberto Ierusalimschy2015-11-026-21/+26
| | | | argument
* now that we have a counter for CallInfos, use it for a moreRoberto Ierusalimschy2015-11-021-2/+3
| | | | accurate value for the memory used by a thread
* macro 'incr_top' replaced by function 'luaD_inctop'. (It is not usedRoberto Ierusalimschy2015-11-025-11/+24
| | | | in critical time pathes, can save a few bytes without the macro)
* added counters for total and individual CallInfo entries (to allowRoberto Ierusalimschy2015-11-022-9/+19
| | | | better syncronization between CallInfo size and stack size)
* in 'luaD_precall', in vararg functions, complete missing parametersRoberto Ierusalimschy2015-11-022-25/+21
| | | | | only after moving them to final place (avoids checking the stack again)
* 'luaO_pushvfstring' now uses 'incr_top' to increment top.Roberto Ierusalimschy2015-11-021-10/+10
|
* using more "conventional" loops in 'luaD_poscall' (probably a littleRoberto Ierusalimschy2015-11-021-7/+13
| | | | more efficient?)
* flag CIST_REENTRY changed to CIST_FRESH (its negation); fresh invocationsRoberto Ierusalimschy2015-11-022-6/+6
| | | | | seem to be less frequent than reentries. (So, avoid setting flag on the frequent case.)
* with 'fast tracks', there is no need to do raw accesses in 'ipairs'Roberto Ierusalimschy2015-10-291-19/+6
|
* corrected comparisons of signed (int) with unsigned (size_t)Roberto Ierusalimschy2015-10-291-3/+3
|
* macro 'buff2num' replaced by its body (it caused more harm than goodRoberto Ierusalimschy2015-10-281-5/+3
| | | | to readability)
* option 'c' in 'string.pack' accepts any string size (truncatingRoberto Ierusalimschy2015-10-281-3/+8
| | | | if larger and padding if smaller)
* function prepares vararg only if it really uses them (chunksRoberto Ierusalimschy2015-10-283-7/+8
| | | | are always declared vararg but seldom uses them)
* OP_SELF can use 'luaV_fastget' specialized for strings, as itRoberto Ierusalimschy2015-10-281-3/+8
| | | | is applied only to string keys
* comments for luaD_precall/luaD_poscallRoberto Ierusalimschy2015-10-281-2/+12
|
* details (avoid 'case' inside block + avoid using one variable forRoberto Ierusalimschy2015-10-281-5/+5
| | | | two roles)
* use macro 'hasjumps' to test whether expression has jumps...Roberto Ierusalimschy2015-10-261-2/+2
|
* hook test in 'luaV_execute' reduced to minimum (rest done inRoberto Ierusalimschy2015-10-221-8/+8
| | | | | | 'luaG_traceexec'; no difference in performance for the non-hook case, but keeps 'luaV_execute' a little simpler) + 'base' updates replaced by 'Protect' (which serves this rule)
* hook test in 'luaV_execute' reduced to minimum (rest done inRoberto Ierusalimschy2015-10-221-2/+4
| | | | 'luaG_traceexec'
* small changes to allow 'precall' to spend time preserving 'func'Roberto Ierusalimschy2015-10-213-28/+42
| | | | only when needed (that is, when stack actually changes)
* generic definitions for float types moved to before variable definitionsRoberto Ierusalimschy2015-10-211-20/+26
| | | | | (so that specific cases can redefine these generic definitions if needed)
* 'condchangemem' also may need to run 'pre'/'pos'Roberto Ierusalimschy2015-10-211-2/+3
|
* added commentsRoberto Ierusalimschy2015-10-201-1/+8
|