Commit message (Collapse) | Author | Age | Files | Lines | ||
---|---|---|---|---|---|---|
... | ||||||
* | small changes to avoid some warnings | Roberto Ierusalimschy | 2011-11-16 | 1 | -9/+5 | |
| | ||||||
* | cannot apply macro 'getstr' over NULL | Roberto Ierusalimschy | 2011-10-31 | 1 | -5/+6 | |
| | ||||||
* | 'lua_setglobal/lua_getglobal' implemented as functions to avoid | Roberto Ierusalimschy | 2011-10-24 | 1 | -1/+25 | |
| | | | | | problems with stack indices (e.g., lua_getglobal(L, lua_tostring(L, -1)) ) | |||||
* | new functions lua_rawsetp/lua_rawgetp | Roberto Ierusalimschy | 2011-10-24 | 1 | -10/+38 | |
| | ||||||
* | lint (unreachable code) | Roberto Ierusalimschy | 2011-09-30 | 1 | -9/+9 | |
| | ||||||
* | detail: new macros for non-valid values | Roberto Ierusalimschy | 2011-09-26 | 1 | -12/+13 | |
| | ||||||
* | bug: __newindex metamethod may not work if metatable is its own | Roberto Ierusalimschy | 2011-08-17 | 1 | -1/+2 | |
| | | | | | metatable + luaV_settable does not create entry when there is a metamethod (and therefore entry is useless) | |||||
* | no more 'luaH_setstr (used only once) + 'luaH_setint' receives value | Roberto Ierusalimschy | 2011-08-09 | 1 | -2/+2 | |
| | | | | to be set. | |||||
* | configuration for NaN trick big-endian + macro 'luai_checknum' to | Roberto Ierusalimschy | 2011-06-13 | 1 | -1/+3 | |
| | | | | | ensure numbers comming from C are not "improper" (some kinds of signaling NaNs) | |||||
* | stricter control (using tag variants) over closure kinds (Lua x C) | Roberto Ierusalimschy | 2011-06-02 | 1 | -56/+61 | |
| | ||||||
* | more uniform names for 'equalobj'-related functions | Roberto Ierusalimschy | 2011-05-31 | 1 | -2/+2 | |
| | ||||||
* | no need for two different implementations for equality (one raw and | Roberto Ierusalimschy | 2011-05-31 | 1 | -2/+2 | |
| | | | | one with metamethods) | |||||
* | lua_arith gets no fake operand for unary minus | Roberto Ierusalimschy | 2011-04-05 | 1 | -7/+15 | |
| | ||||||
* | full collection does not restart collector + avoid changing GC | Roberto Ierusalimschy | 2010-12-29 | 1 | -7/+3 | |
| | | | | state if an error happens in a step | |||||
* | change in the relationship between totalbytes and GCdebt - luaM_realloc_ | Roberto Ierusalimschy | 2010-12-20 | 1 | -4/+4 | |
| | | | | is too critical to update two counters | |||||
* | better control for GC running or stopped | Roberto Ierusalimschy | 2010-12-20 | 1 | -6/+8 | |
| | ||||||
* | finalizers (__gc) for tables | Roberto Ierusalimschy | 2010-11-26 | 1 | -2/+3 | |
| | ||||||
* | code for conversion macros moved from luaconf to llimits + 'uint' | Roberto Ierusalimschy | 2010-11-03 | 1 | -3/+3 | |
| | | | | renamed to 'unsigned' in those macros | |||||
* | new type lua_Unsigned and corresponding projection/injection functions | Roberto Ierusalimschy | 2010-10-25 | 1 | -1/+28 | |
| | ||||||
* | corrected warnings from different compilers (mostly casts and small | Roberto Ierusalimschy | 2010-10-25 | 1 | -5/+3 | |
| | | | | details) | |||||
* | 'lua_[gs]etupvalue' may work even without debug information | Roberto Ierusalimschy | 2010-09-07 | 1 | -2/+6 | |
| | | | | (that is, without upvalue names) | |||||
* | name "_ENV" configurable through 'luaconf.h' | Roberto Ierusalimschy | 2010-09-07 | 1 | -2/+2 | |
| | ||||||
* | new parameter 'majorinc' to control frequency of major collections | Roberto Ierusalimschy | 2010-09-03 | 1 | -1/+6 | |
| | | | | in generational mode | |||||
* | api checks to ensure that thread is OK when using lua_call/lua_pcall | Roberto Ierusalimschy | 2010-08-04 | 1 | -1/+3 | |
| | ||||||
* | 'lua_[gs]etenv' -> 'lua_[gs]etuservalue' | Roberto Ierusalimschy | 2010-07-25 | 1 | -3/+3 | |
| | ||||||
* | functions lua_tonumber/lua_tointeger replaced by lua_tonumberx/lua_tointegerx | Roberto Ierusalimschy | 2010-07-02 | 1 | -6/+13 | |
| | | | | that have an extra out parameter with conversion status | |||||
* | better names for barrier macros | Roberto Ierusalimschy | 2010-06-04 | 1 | -4/+4 | |
| | ||||||
* | new macro MAXUPVAL (maximum number of upvalues per closure) | Roberto Ierusalimschy | 2010-05-31 | 1 | -3/+3 | |
| | ||||||
* | in 'absindex', do not need to call gettop (can inline it) | Roberto Ierusalimschy | 2010-05-14 | 1 | -2/+2 | |
| | ||||||
* | new API function 'lua_absindex' | Roberto Ierusalimschy | 2010-05-12 | 1 | -3/+13 | |
| | ||||||
* | stupid bug when calling 'luaC_changemode' (in function lua_gc) | Roberto Ierusalimschy | 2010-05-07 | 1 | -3/+6 | |
| | ||||||
* | new function 'luaC_changemode' | Roberto Ierusalimschy | 2010-05-05 | 1 | -9/+4 | |
| | ||||||
* | new way to control GC speed (keeping a 'debt' counter) | Roberto Ierusalimschy | 2010-04-29 | 1 | -7/+7 | |
| | ||||||
* | upvalue barriers for Lua functions must act on the upvalue itself, | Roberto Ierusalimschy | 2010-04-20 | 1 | -6/+10 | |
| | | | | not on its closure | |||||
* | in lua_gc/step, 'luaC_step' changes GCthreshold, so there was little | Roberto Ierusalimschy | 2010-04-19 | 1 | -4/+2 | |
| | | | | control over the real step size. | |||||
* | "light C function" is a better name than "C-function pointer" | Roberto Ierusalimschy | 2010-04-18 | 1 | -5/+5 | |
| | ||||||
* | first implementation of light C functions | Roberto Ierusalimschy | 2010-04-14 | 1 | -27/+41 | |
| | ||||||
* | 'lua_pushstring' now uses 'luaS_new' | Roberto Ierusalimschy | 2010-04-05 | 1 | -3/+11 | |
| | ||||||
* | option to return GC to normal (incremental, non generational) mode | Roberto Ierusalimschy | 2010-04-02 | 1 | -1/+5 | |
| | ||||||
* | global table now is only kept in the registry | Roberto Ierusalimschy | 2010-03-29 | 1 | -5/+11 | |
| | ||||||
* | no more fenvs! | Roberto Ierusalimschy | 2010-03-26 | 1 | -68/+29 | |
| | ||||||
* | major collections in generational mode | Roberto Ierusalimschy | 2010-03-25 | 1 | -9/+15 | |
| | ||||||
* | draft version of a generational mode for garbage collection. (Not well | Roberto Ierusalimschy | 2010-03-22 | 1 | -1/+7 | |
| | | | | tested; no major collections; ...) | |||||
* | first step towards _ENV: all chunks have an puvalues _ENV with the | Roberto Ierusalimschy | 2010-03-08 | 1 | -1/+7 | |
| | | | | global table | |||||
* | field 'oldtop' renamed to 'extra', as it can be used for other | Roberto Ierusalimschy | 2010-02-09 | 1 | -2/+2 | |
| | | | | purposes | |||||
* | new function 'luaL_cpcall' | Roberto Ierusalimschy | 2010-01-21 | 1 | -10/+1 | |
| | ||||||
* | "no value" added to array luaT_typenames + occurrences of "userdata" | Roberto Ierusalimschy | 2010-01-13 | 1 | -2/+2 | |
| | | | | in that array unified in a single address | |||||
* | added casts from int to enumerations to follow C++ rules | Roberto Ierusalimschy | 2010-01-11 | 1 | -2/+3 | |
| | ||||||
* | removed parentheses around some function names in their definitions | Roberto Ierusalimschy | 2010-01-08 | 1 | -3/+3 | |
| | ||||||
* | new api_check that 'pcallk' cannot be called inside hooks | Roberto Ierusalimschy | 2010-01-04 | 1 | -1/+3 | |
| |