summaryrefslogtreecommitdiff
path: root/lobject.h (follow)
Commit message (Collapse)AuthorAgeFilesLines
* several new commentsRoberto Ierusalimschy2010-07-261-27/+43
|
* Lua closures are cached for reuseRoberto Ierusalimschy2010-06-041-1/+2
|
* slightly better definition for 'changenvalue'Roberto Ierusalimschy2010-05-071-3/+2
|
* "light C function" is a better name than "C-function pointer"Roberto Ierusalimschy2010-04-181-6/+6
|
* first implementation of light C functionsRoberto Ierusalimschy2010-04-141-9/+30
|
* new macro LUA_NUMTAGSRoberto Ierusalimschy2010-04-121-10/+4
|
* no more fenvs!Roberto Ierusalimschy2010-03-261-3/+2
|
* first version of _ENV; no more global variablesRoberto Ierusalimschy2010-03-121-2/+1
|
* 'setobj' must assing fields one by one, to allow trick of usingRoberto Ierusalimschy2010-01-081-3/+5
| | | | pad space in table keys
* new macros 'LUAI_DDEC'/'LUAI_DDEF' to better control declarations andRoberto Ierusalimschy2009-11-191-2/+2
| | | | definitions of non-static variables
* several small changes to simplify changing TValue if neededRoberto Ierusalimschy2009-11-061-19/+17
|
* better control over accesses to TValue fieldsRoberto Ierusalimschy2009-11-051-28/+31
|
* first implementation of lexical environmentsRoberto Ierusalimschy2009-09-301-1/+2
|
* information about upvalues (where they come from) kept in Proto structure,Roberto Ierusalimschy2009-09-281-4/+12
| | | | instead of sequence of pseudo-opcodes after OP_CLOSURE
* new macro 'getproto'Roberto Ierusalimschy2009-07-151-1/+2
|
* new macro 'changenvalue'Roberto Ierusalimschy2009-06-181-1/+4
|
* new function 'luaO_arith' to perform basic arithmetic operationsRoberto Ierusalimschy2009-06-171-1/+2
|
* no more support for old-style varargsRoberto Ierusalimschy2009-03-261-7/+1
|
* bug: string at the end of TString must consider the entire TStringRoberto Ierusalimschy2008-08-051-2/+2
| | | | entity, not only its 'tsv' part
* 'ceillog2' now is exported (other modules may need it)Roberto Ierusalimschy2008-01-301-1/+2
|
* luaO_log2 can be private to ltable.cRoberto Ierusalimschy2007-04-101-4/+1
|
* avoid trailing white spacesRoberto Ierusalimschy2006-09-111-2/+2
|
* unused macro removedRoberto Ierusalimschy2006-01-181-4/+1
|
* avoids type punning for table keysRoberto Ierusalimschy2006-01-101-5/+9
|
* detailRoberto Ierusalimschy2005-10-241-2/+2
|
* bug: last tag is not the number of tags...Roberto Ierusalimschy2005-06-131-5/+7
|
* better control for compatibility code for varargsRoberto Ierusalimschy2005-06-131-3/+6
|
* new mark LUAI_DATA for extern dataRoberto Ierusalimschy2005-06-061-2/+2
|
* warnings in VS .NetRoberto Ierusalimschy2005-05-311-2/+2
|
* debug information for last line of a function definitionRoberto Ierusalimschy2005-05-051-2/+3
|
* added LUAI_FUNC to functions not in the APIRoberto Ierusalimschy2005-04-251-11/+10
|
* C functions and userdata also have environmentsRoberto Ierusalimschy2005-02-181-3/+4
|
* cleaner way to remark open upvaluesRoberto Ierusalimschy2005-01-181-2/+8
|
* change in hash algorithm so that it does not need empty slotRoberto Ierusalimschy2005-01-051-2/+4
| | | | (tables can be 100% full)
* better (correct?) way to handle `next' over removed keysRoberto Ierusalimschy2004-12-041-1/+2
|
* better implementation for `floating-point bytes'Roberto Ierusalimschy2004-11-011-2/+2
|
* small optimization for table size in machines with double allignmentRoberto Ierusalimschy2004-10-061-6/+13
|
* new way to use `vararg' parameters (with `...')Roberto Ierusalimschy2004-05-311-1/+5
|
* better way to control open upvaluesRoberto Ierusalimschy2004-03-151-2/+1
|
* added include to stdarg.h (as it uses vararg facilities)Roberto Ierusalimschy2004-02-201-1/+5
|
* more and better tools (assertions & inspectors) to check incremental GCRoberto Ierusalimschy2004-02-161-10/+10
|
* `TObject' renamed to `TValue' + other name changes and better assertionsRoberto Ierusalimschy2003-12-101-48/+55
| | | | for incremental garbage collection
* towards incremental GCRoberto Ierusalimschy2003-11-181-1/+2
|
* parser fully reentrant(!)Roberto Ierusalimschy2003-08-271-15/+22
|
* Lua does not need all those different types...Roberto Ierusalimschy2003-04-281-2/+2
|
* name changes to avoid name collision between macros and variablesRoberto Ierusalimschy2003-03-181-2/+1
|
* small optimization for sizes of array constructorsRoberto Ierusalimschy2003-02-181-2/+3
|
* different variables for number of upvalues and size of upvalue arrayRoberto Ierusalimschy2003-02-111-2/+3
| | | | (makes code clearer)
* new functions to manipulate upvales (get/setupvalue)Roberto Ierusalimschy2002-12-191-2/+3
|
* better code to signal write barriersRoberto Ierusalimschy2002-11-141-3/+5
|