| Commit message (Collapse) | Author | Age | Files | Lines |
... | |
| |
|
|
|
|
| |
out of the large EVP_DigestInit(3). No text change.
|
|
|
|
|
|
|
|
| |
undocumented because they are unused outside libcrypto according
to codesearch.debian.net and should probably not be public: they seem
hardly useful even for implementing custom EVP_CIPHER algorithms.
tb@ came to similar conclusions regarding these two functions.
|
|
|
|
| |
OK tb@
|
|
|
|
|
|
|
| |
Reported by Viktor Szakats in
https://github.com/libressl/portable/issues/910
ok job
|
|
|
|
|
|
|
|
| |
The text was misleading before and after the improvement
in obj_dat.c rev. 1.61. The way i'm fixing the documentation
here takes that improvement into account.
Also add a CAVEATS section about adding incomplete objects.
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
There is no need for a helper function to obfuscate lh_ADDED_OBJ_new().
Just call the real thing directly.
Adding an object with a NID of NID_undef basically amounts to disabling
a built-in OID. It does so in an incoherent fashion and the caller can't
easily tell success from failure of the operation. Arguably the result is
a corrupted objects table.
Let's not allow adding such an object in an attempt at keeping things
slightly more coherent.
Issue noted and initial diff by schwarze while writing documentation
ok schwarze
|
| |
|
| |
|
|
|
|
| |
in particular saying which API functions each flag affects
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* Integrate the leftovers of the former NOTES section into the main text,
resulting in a more logical order of information.
* Make many descriptions more precise and tweak many wordings.
For example, the description of OBJ_cmp(3) was totally misleading.
Add a CAVEATS section explaining the scary ownership contracts
of the functions returning ASN1_OBJECT pointers.
Move the discussion of NID_undef to the BUGS section because the
statement "objects which are not in the table have the NID value
NID_undef" was misleading in more than one way.
Considering that an API as fundamental as this one contains such a
gigantic amount of quirks and traps and gaps makes me shudder.
|
| |
|
|
|
|
|
|
| |
/usr/src/lib/libcrypto/whrlpool/wp_local.h:5:1: error: unknown type name '__BEGIN_HIDDEN_DECLS'
ok tb@
|
| |
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
* more precision what the CIPHER_CTX functions do
* more precision what an NID is
* avoid talking about RC2, use AES-256 for an example instead
* clarify that block sizes are measured in bytes
* mention additional restrictions regarding valid block sizes
* add the missing description of the *_flags(3) functions
* mention the public mask constant EVP_CIPH_MODE
* add three missing modes that can occur as return values
* add the missing entries for *_flags(3) and *_mode(3) below RETURN VALUES
* tweak various wordings for precision and conciseness
|
|
|
|
|
|
| |
It currently returns NULL. This is OpenSSL 4088b926 + De Morgan.
ok jsing
|
| |
|
|
|
|
|
|
|
|
|
|
|
| |
and EVP_CIPHER_CTX_set_flags(3) out of the excessively large and
unwieldy EVP_EncryptInit(3). This causes a number of inaccuracies
and gaps to stand out, but i'm not mixing text changes or content
additions into this split.
Using very useful feedback from tb@ regarding what belongs together
and how important the various functions are. I refrained from bothering
him with the complete patch, but he likes the general direction.
|
|
|
|
| |
OK tb@
|
|
|
|
|
|
|
|
|
|
| |
The function prototypes in the SYNOPSIS don't look great, but schwarze
assures me that this is how it is supposed to be. It is rather strange
that OpenSSL chose to sprinkle OPENSSL_init_crypto() calls into these
four functions rather than two inside OBJ_NAME_do_all{,_sorted}(3).
Surely there was a good reason for that.
With input and fixes from schwarze
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
The stack of subject alternative names from the issuer is parsed using
X509V3_EXT_d2i(), so it must be freed with sk_GENERAL_NAME_pop_free().
It's not worth doing complicated ownership handling when the individual
alternative names can be copied with GENERAL_NAME_dup().
Previously, ialt and its remaining members would be leaked when the call
to sk_GENERAL_NAME_push() failed halfway through.
This is only reachable via the issuer:copy x509v3.cnf(5) directive.
ok jsing
|
|
|
|
|
|
| |
Except if backward compatibility with older LibreSSL and OpenSSL versions
is explicitly needed, ecdsa.h and ecdh.h should no longer be used. They
are now trivial wrappers of ec.h.
|
|
|
|
|
| |
into a new EVP_sha1(3) manual page, and also mention EVP_md4(3) there.
Using input from tb@ and jsing@, who like the general direction.
|
|
|
|
| |
the "len" argument and the return value of EVP_PKEY_asn1_find_str(3)
|
| |
|
| |
|
|
|
|
| |
and add the missing link to evp(3)
|
|
|
|
|
|
|
| |
Put it here rather than into EVP_EncryptInit(3) because similar to
EVP_CIPHER_CTX_get_cipher_data(3), application software should not
use it. These functions will likely not be needed except by people
implementing custom encryption algorithms.
|
|
|
|
| |
and EVP_CIPHER_CTX_encrypting(3) from scratch
|
| |
|
| |
|
|
|
|
|
| |
and be more specific below RETURN VALUES;
OK tb@
|
|
|
|
|
|
| |
and EVP_CIPHER_CTX_set_cipher_data(3).
Import the manual page from the OpenSSL 1.1 branch, which is still
under a free licence, with several improvements by me.
|
| |
|
|
|
|
| |
OK tb@ jsing@
|
| |
|
|
|
|
|
| |
Fix some copy-paste errors in the prototypes, tweak the explanatory text
and add some more details.
|
| |
|
|
|
|
|
| |
These and EVP_{add,remove}_{cipher,digest}_alias() are mostly for internal
use.
|
| |
|
|
|
|
|
| |
Make it a static function and remove its prototype from the internal
header.
|
|
|
|
|
|
|
| |
More idiomatic error checking and drop an always false test for !*pos. Use
a slightly closer approximation to actual English sentences in comments.
ok jsing
|
|
|
|
|
|
| |
Rename cmsbio into cms_bio and use {,in_}content_bio for {,i}cont.
ok jsing
|
|
|
|
|
|
|
|
| |
RFC 7539 was superseded by RFC 8439, incorporating errata and making
editorial improvements. Very little of substance changed, in particular
section numbers remain the same.
Prompted by a question from schwarze
|
|
|
|
|
|
|
|
| |
Incorrect OpenSSL documentation was moved here and inherited parts of a
comment that was fixed in evp/e_chacha.c r1.13. Adjust the manual page
accordingly.
Discussed with schwarze
|
|
|
|
|
|
|
|
|
|
|
| |
EVP_chacha20() was aligned to follow OpenSSL's nonconformant implementation
during a2k20 by djm and myself in an effort to allow OpenSSH to use the
OpenSSL 1.1 API. Some corresponding OpenSSL 1.1 documentation was imported
at the same time. A comment attempted to translate between implementation
and the incorrect documentation, which was necessarily gibberish. Improve
the situation by rephrasing and dropping nonsensical bits.
Prompted by a question of schwarze
|
|
|
|
|
|
|
|
|
| |
Mention portability considerations regarding the EVP_AEAD API.
Avoid confusing words like "older" and "native" API, be specific.
Mention RFC 7905.
Move publications we don't implement from STANDARDS to CAVEATS.
Based on input from jsing@ and tb@, OK tb@.
|
|
|
|
| |
ok jsing
|