aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSatoshi Yasushima <yasushima-gd@users.noreply.github.com>2016-08-25 18:17:27 +0900
committerSatoshi Yasushima <yasushima-gd@users.noreply.github.com>2016-08-25 18:17:27 +0900
commit829b21581fc93085faeced35b3c75376b0de6ae2 (patch)
treeb74c39e6806268b6ee2d5ffd72f0d98e483d2a92 /CMakeLists.txt
parent971892766db26560f7cc34b78750cac149867425 (diff)
downloadportable-829b21581fc93085faeced35b3c75376b0de6ae2.tar.gz
portable-829b21581fc93085faeced35b3c75376b0de6ae2.tar.bz2
portable-829b21581fc93085faeced35b3c75376b0de6ae2.zip
build Windows DLL on CMake
like below. * libcrypto-38.dll * libssl-39.dll * libtls-11.dll
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f4300dd..e546ea4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -240,7 +240,7 @@ if(CMAKE_SYSTEM_NAME MATCHES "SunOS")
240 set(OPENSSL_LIBS ${OPENSSL_LIBS} nsl socket) 240 set(OPENSSL_LIBS ${OPENSSL_LIBS} nsl socket)
241endif() 241endif()
242 242
243if(NOT (CMAKE_SYSTEM_NAME MATCHES "(Darwin|MINGW|CYGWIN)" OR MSVC)) 243if(NOT (CMAKE_SYSTEM_NAME MATCHES "(Darwin|CYGWIN)"))
244 set(BUILD_SHARED true) 244 set(BUILD_SHARED true)
245endif() 245endif()
246 246