aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorkinichiro <kinichiro.inoguchi@gmail.com>2019-05-19 13:20:06 +0900
committerBrent Cook <busterb@gmail.com>2019-06-10 06:49:34 -0500
commitbbb662b69c48c07d93e642548c0f71ebbdc06d93 (patch)
tree3a174b52524071b7151b54a4c618315a06886ad7 /CMakeLists.txt
parentc6f8ca2bc6b5bd8ca8842326f74e0cff007766ad (diff)
downloadportable-bbb662b69c48c07d93e642548c0f71ebbdc06d93.tar.gz
portable-bbb662b69c48c07d93e642548c0f71ebbdc06d93.tar.bz2
portable-bbb662b69c48c07d93e642548c0f71ebbdc06d93.zip
Fix masm build
- Fix masm operators and comments - Add -DOPENSSL_NO_ASM only if not 64 bit build - Add -DCMAKE_INSTALL_PREFIX to avoid build error
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af287a4..a0b0599 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -289,7 +289,7 @@ if(ENABLE_ASM)
289 endif() 289 endif()
290 elseif(APPLE AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64") 290 elseif(APPLE AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64")
291 set(HOST_ASM_MACOSX_X86_64 true) 291 set(HOST_ASM_MACOSX_X86_64 true)
292 elseif(MSVC AND "${CMAKE_SYSTEM_PROCESSOR}" MATCHES "AMD64") 292 elseif(MSVC AND "${CMAKE_GENERATOR}" MATCHES "Win64")
293 # XXX Disabled for now, CMake's MASM support seems to either never 293 # XXX Disabled for now, CMake's MASM support seems to either never
294 # build supply ASM or build it with the C compiler in a mode where it 294 # build supply ASM or build it with the C compiler in a mode where it
295 # does not parse correctly. It might be easier to get NASM support working. 295 # does not parse correctly. It might be easier to get NASM support working.