diff options
author | Jeff Davey <jdavey@apple.com> | 2015-08-18 13:20:19 -0600 |
---|---|---|
committer | Brent Cook <bcook@openbsd.org> | 2015-08-28 13:17:12 -0500 |
commit | 9caf754a59f166bcf62a2cf84f82720ae110ab74 (patch) | |
tree | 4065163ca9a357bb78d3357ad4417461ea4eeeef /CMakeLists.txt | |
parent | 2f2f08e60c8ade1840c2ff31ec36e934ef6d03ec (diff) | |
download | portable-9caf754a59f166bcf62a2cf84f82720ae110ab74.tar.gz portable-9caf754a59f166bcf62a2cf84f82720ae110ab74.tar.bz2 portable-9caf754a59f166bcf62a2cf84f82720ae110ab74.zip |
Add install targets and shared libraries to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 2734bad..5560f21 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -6,6 +6,21 @@ project (LibreSSL) | |||
6 | 6 | ||
7 | enable_testing() | 7 | enable_testing() |
8 | 8 | ||
9 | set(SSL_MAJOR_VERSION "35") | ||
10 | set(SSL_MINOR_VERSION "0") | ||
11 | set(SSL_REVISION "0") | ||
12 | set(SSL_VERSION "${SSL_MAJOR_VERSION}.${SSL_MINOR_VERSION}.${SSL_REVISION}") | ||
13 | |||
14 | set(CRYPTO_MAJOR_VERSION "35") | ||
15 | set(CRYPTO_MINOR_VERSION "0") | ||
16 | set(CRYPTO_REVISION "0") | ||
17 | set(CRYPTO_VERSION "${CRYPTO_MAJOR_VERSION}.${CRYPTO_MINOR_VERSION}.${CRYPTO_REVISION}") | ||
18 | |||
19 | set(TLS_MAJOR_VERSION "6") | ||
20 | set(TLS_MINOR_VERSION "0") | ||
21 | set(TLS_REVISION "0") | ||
22 | set(TLS_VERSION "${TLS_MAJOR_VERSION}.${TLS_MINOR_VERSION}.${TLS_REVISION}") | ||
23 | |||
9 | if(CMAKE_SYSTEM_NAME MATCHES "OpenBSD") | 24 | if(CMAKE_SYSTEM_NAME MATCHES "OpenBSD") |
10 | add_definitions(-DHAVE_ATTRIBUTE__BOUNDED__) | 25 | add_definitions(-DHAVE_ATTRIBUTE__BOUNDED__) |
11 | endif() | 26 | endif() |
@@ -147,6 +162,8 @@ add_subdirectory(crypto) | |||
147 | add_subdirectory(ssl) | 162 | add_subdirectory(ssl) |
148 | add_subdirectory(apps) | 163 | add_subdirectory(apps) |
149 | add_subdirectory(tls) | 164 | add_subdirectory(tls) |
165 | add_subdirectory(include) | ||
150 | if(NOT MSVC) | 166 | if(NOT MSVC) |
167 | add_subdirectory(man) | ||
151 | add_subdirectory(tests) | 168 | add_subdirectory(tests) |
152 | endif() | 169 | endif() |