aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <bcook@openbsd.org>2015-09-07 01:05:33 -0500
committerBrent Cook <bcook@openbsd.org>2015-09-07 01:05:33 -0500
commitca56c332e3356118441c955e690f6727a9928b69 (patch)
tree4df1dc6d552b44dea1cca3d94c0c4a30d66c8218 /CMakeLists.txt
parent4078416c36124e86275b093519f7c0d772ee25b8 (diff)
downloadportable-ca56c332e3356118441c955e690f6727a9928b69.tar.gz
portable-ca56c332e3356118441c955e690f6727a9928b69.tar.bz2
portable-ca56c332e3356118441c955e690f6727a9928b69.zip
disable shared CMake builds for OS X / Windows for now
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5c5408..0e4c000 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -158,6 +158,10 @@ if(CMAKE_HOST_WIN32)
158 set(OPENSSL_LIBS ${OPENSSL_LIBS} ws2_32) 158 set(OPENSSL_LIBS ${OPENSSL_LIBS} ws2_32)
159endif() 159endif()
160 160
161if(NOT (CMAKE_SYSTEM_NAME MATCHES "Darwin" OR MSVC))
162 set(BUILD_SHARED true)
163endif()
164
161add_subdirectory(crypto) 165add_subdirectory(crypto)
162add_subdirectory(ssl) 166add_subdirectory(ssl)
163add_subdirectory(apps) 167add_subdirectory(apps)