aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <bcook@openbsd.org>2015-10-15 14:32:16 -0500
committerBrent Cook <bcook@openbsd.org>2015-10-15 14:32:16 -0500
commitdadeeb0a2ed5e21bb90bb819a13c1bf9f4d1accf (patch)
tree5152db9296cd294ab4e35fe5d7a57fda56044d65 /CMakeLists.txt
parentcac089b5d6f4b0237f8221d18079735f1d3e7c72 (diff)
downloadportable-dadeeb0a2ed5e21bb90bb819a13c1bf9f4d1accf.tar.gz
portable-dadeeb0a2ed5e21bb90bb819a13c1bf9f4d1accf.tar.bz2
portable-dadeeb0a2ed5e21bb90bb819a13c1bf9f4d1accf.zip
check for timegm in cmake builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ed9cb1f..e4cf7ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,6 +121,11 @@ if(HAVE_STRSEP)
121 add_definitions(-DHAVE_STRSEP) 121 add_definitions(-DHAVE_STRSEP)
122endif() 122endif()
123 123
124check_function_exists(timegm HAVE_TIMEGM)
125if(HAVE_TIMEGM)
126 add_definitions(-DHAVE_TIMEGM)
127endif()
128
124check_function_exists(arc4random_buf HAVE_ARC4RANDOM_BUF) 129check_function_exists(arc4random_buf HAVE_ARC4RANDOM_BUF)
125if(HAVE_ARC4RANDOM_BUF) 130if(HAVE_ARC4RANDOM_BUF)
126 add_definitions(-DHAVE_ARC4RANDOM_BUF) 131 add_definitions(-DHAVE_ARC4RANDOM_BUF)