aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <bcook@openbsd.org>2015-09-09 05:15:06 -0500
committerBrent Cook <bcook@openbsd.org>2015-09-09 06:03:52 -0500
commitadfb2bf72257c4d622f4be8f897c5ddafa4e58ae (patch)
tree3b6969d7328069b41d28109e667df8493356600a /CMakeLists.txt
parent5f4e95e7c16a63bbda4f3654126cc81806f779d8 (diff)
downloadportable-adfb2bf72257c4d622f4be8f897c5ddafa4e58ae.tar.gz
portable-adfb2bf72257c4d622f4be8f897c5ddafa4e58ae.tar.bz2
portable-adfb2bf72257c4d622f4be8f897c5ddafa4e58ae.zip
Do not build lib-objects targets if we are just building static libs.
This confuses some cmake targets.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e4c000..2aed0c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,8 @@ add_definitions(-DLIBRESSL_INTERNAL)
36add_definitions(-DOPENSSL_NO_HW_PADLOCK) 36add_definitions(-DOPENSSL_NO_HW_PADLOCK)
37add_definitions(-DOPENSSL_NO_ASM) 37add_definitions(-DOPENSSL_NO_ASM)
38 38
39set(CMAKE_POSITION_INDEPENDENT_CODE true)
40
39if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang") 41if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
40 add_definitions(-Wno-pointer-sign) 42 add_definitions(-Wno-pointer-sign)
41endif() 43endif()