aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Stancliff <matt@genges.com>2017-06-15 23:11:13 -0400
committerMatt Stancliff <matt@genges.com>2017-06-15 23:11:13 -0400
commitfe79df3c9060550064faad0bc0b1382e4c7454bd (patch)
treeac3d45f7d495c05cbff02c3adb9d90f4108f6b4e /CMakeLists.txt
parent8b80bcdad82a57d195381a150aa2690f188b127e (diff)
downloadportable-fe79df3c9060550064faad0bc0b1382e4c7454bd.tar.gz
portable-fe79df3c9060550064faad0bc0b1382e4c7454bd.tar.bz2
portable-fe79df3c9060550064faad0bc0b1382e4c7454bd.zip
Fix CMake module include path
Need to search the current directory, not the overall project root directory if this is being included as a sub-dependency of another project.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94e4d0b..570e0ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ include(CheckLibraryExists)
4include(CheckIncludeFiles) 4include(CheckIncludeFiles)
5include(CheckTypeSize) 5include(CheckTypeSize)
6 6
7set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}" ${CMAKE_MODULE_PATH}) 7set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}" ${CMAKE_MODULE_PATH})
8include(cmake_export_symbol) 8include(cmake_export_symbol)
9 9
10project (LibreSSL C) 10project (LibreSSL C)