aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <bcook@openbsd.org>2015-08-19 19:16:29 -0500
committerBrent Cook <bcook@openbsd.org>2015-08-19 19:18:03 -0500
commit61fe482d467cd79870275905f456f3cf7705918f (patch)
tree490df965acabd10999eb37115eddfc064afe7b6a /CMakeLists.txt
parent5461dea7f141d78d1d0bb4c4f17be9b15680fa96 (diff)
downloadportable-61fe482d467cd79870275905f456f3cf7705918f.tar.gz
portable-61fe482d467cd79870275905f456f3cf7705918f.tar.bz2
portable-61fe482d467cd79870275905f456f3cf7705918f.zip
derive version numbers from VERSION files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 14 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5560f21..b5c5408 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,20 +6,20 @@ project (LibreSSL)
6 6
7enable_testing() 7enable_testing()
8 8
9set(SSL_MAJOR_VERSION "35") 9file(READ ${CMAKE_SOURCE_DIR}/ssl/VERSION SSL_VERSION)
10set(SSL_MINOR_VERSION "0") 10string(STRIP ${SSL_VERSION} SSL_VERSION)
11set(SSL_REVISION "0") 11string(REPLACE ":" "." SSL_VERSION ${SSL_VERSION})
12set(SSL_VERSION "${SSL_MAJOR_VERSION}.${SSL_MINOR_VERSION}.${SSL_REVISION}") 12string(REGEX REPLACE "\\..*" "" SSL_MAJOR_VERSION ${SSL_VERSION})
13 13
14set(CRYPTO_MAJOR_VERSION "35") 14file(READ ${CMAKE_SOURCE_DIR}/crypto/VERSION CRYPTO_VERSION)
15set(CRYPTO_MINOR_VERSION "0") 15string(STRIP ${CRYPTO_VERSION} CRYPTO_VERSION)
16set(CRYPTO_REVISION "0") 16string(REPLACE ":" "." CRYPTO_VERSION ${CRYPTO_VERSION})
17set(CRYPTO_VERSION "${CRYPTO_MAJOR_VERSION}.${CRYPTO_MINOR_VERSION}.${CRYPTO_REVISION}") 17string(REGEX REPLACE "\\..*" "" CRYPTO_MAJOR_VERSION ${CRYPTO_VERSION})
18 18
19set(TLS_MAJOR_VERSION "6") 19file(READ ${CMAKE_SOURCE_DIR}/tls/VERSION TLS_VERSION)
20set(TLS_MINOR_VERSION "0") 20string(STRIP ${TLS_VERSION} TLS_VERSION)
21set(TLS_REVISION "0") 21string(REPLACE ":" "." TLS_VERSION ${TLS_VERSION})
22set(TLS_VERSION "${TLS_MAJOR_VERSION}.${TLS_MINOR_VERSION}.${TLS_REVISION}") 22string(REGEX REPLACE "\\..*" "" TLS_MAJOR_VERSION ${TLS_VERSION})
23 23
24if(CMAKE_SYSTEM_NAME MATCHES "OpenBSD") 24if(CMAKE_SYSTEM_NAME MATCHES "OpenBSD")
25 add_definitions(-DHAVE_ATTRIBUTE__BOUNDED__) 25 add_definitions(-DHAVE_ATTRIBUTE__BOUNDED__)