aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeff Davey <jdavey@apple.com>2015-08-18 13:20:19 -0600
committerJeff Davey <jdavey@apple.com>2015-08-18 13:20:19 -0600
commit5461dea7f141d78d1d0bb4c4f17be9b15680fa96 (patch)
tree400e930cf75c4d390590a8ce0f5fe2f779124584 /CMakeLists.txt
parent9aa4e1d96095c5bde62aa541a6b3aa48110cc5b0 (diff)
downloadportable-5461dea7f141d78d1d0bb4c4f17be9b15680fa96.tar.gz
portable-5461dea7f141d78d1d0bb4c4f17be9b15680fa96.tar.bz2
portable-5461dea7f141d78d1d0bb4c4f17be9b15680fa96.zip
Add install targets and shared libraries to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2734bad..5560f21 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,21 @@ project (LibreSSL)
6 6
7enable_testing() 7enable_testing()
8 8
9set(SSL_MAJOR_VERSION "35")
10set(SSL_MINOR_VERSION "0")
11set(SSL_REVISION "0")
12set(SSL_VERSION "${SSL_MAJOR_VERSION}.${SSL_MINOR_VERSION}.${SSL_REVISION}")
13
14set(CRYPTO_MAJOR_VERSION "35")
15set(CRYPTO_MINOR_VERSION "0")
16set(CRYPTO_REVISION "0")
17set(CRYPTO_VERSION "${CRYPTO_MAJOR_VERSION}.${CRYPTO_MINOR_VERSION}.${CRYPTO_REVISION}")
18
19set(TLS_MAJOR_VERSION "6")
20set(TLS_MINOR_VERSION "0")
21set(TLS_REVISION "0")
22set(TLS_VERSION "${TLS_MAJOR_VERSION}.${TLS_MINOR_VERSION}.${TLS_REVISION}")
23
9if(CMAKE_SYSTEM_NAME MATCHES "OpenBSD") 24if(CMAKE_SYSTEM_NAME MATCHES "OpenBSD")
10 add_definitions(-DHAVE_ATTRIBUTE__BOUNDED__) 25 add_definitions(-DHAVE_ATTRIBUTE__BOUNDED__)
11endif() 26endif()
@@ -147,6 +162,8 @@ add_subdirectory(crypto)
147add_subdirectory(ssl) 162add_subdirectory(ssl)
148add_subdirectory(apps) 163add_subdirectory(apps)
149add_subdirectory(tls) 164add_subdirectory(tls)
165add_subdirectory(include)
150if(NOT MSVC) 166if(NOT MSVC)
167 add_subdirectory(man)
151 add_subdirectory(tests) 168 add_subdirectory(tests)
152endif() 169endif()