diff options
author | kinichiro <kinichiro.inoguchi@gmail.com> | 2018-03-27 21:40:52 +0900 |
---|---|---|
committer | kinichiro <kinichiro.inoguchi@gmail.com> | 2018-03-27 21:40:52 +0900 |
commit | 650487dbe908c2d42552d682be6e00ff937029ed (patch) | |
tree | 1c8f4066ecead83b5c00f82533609efa7a1f691e /CMakeLists.txt | |
parent | 55c0cacca0fe675a15389dc175088528a5d2cd00 (diff) | |
download | portable-650487dbe908c2d42552d682be6e00ff937029ed.tar.gz portable-650487dbe908c2d42552d682be6e00ff937029ed.tar.bz2 portable-650487dbe908c2d42552d682be6e00ff937029ed.zip |
Build and run regression tests against shared libraries with CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 1c6bd67..6b20778 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -274,11 +274,11 @@ if(HAVE_CLOCK_GETTIME) | |||
274 | endif() | 274 | endif() |
275 | 275 | ||
276 | if(CMAKE_SYSTEM_NAME MATCHES "Linux") | 276 | if(CMAKE_SYSTEM_NAME MATCHES "Linux") |
277 | set(OPENSSL_LIBS ${OPENSSL_LIBS} pthread) | ||
277 | check_library_exists(rt clock_gettime "time.h" HAVE_CLOCK_GETTIME) | 278 | check_library_exists(rt clock_gettime "time.h" HAVE_CLOCK_GETTIME) |
278 | if (HAVE_CLOCK_GETTIME) | 279 | if (HAVE_CLOCK_GETTIME) |
279 | set(OPENSSL_LIBS ${OPENSSL_LIBS} rt) | 280 | set(OPENSSL_LIBS ${OPENSSL_LIBS} rt) |
280 | endif() | 281 | endif() |
281 | set(OPENSSL_LIBS ${OPENSSL_LIBS} pthread) | ||
282 | endif() | 282 | endif() |
283 | if(CMAKE_SYSTEM_NAME MATCHES "HP-UX") | 283 | if(CMAKE_SYSTEM_NAME MATCHES "HP-UX") |
284 | set(OPENSSL_LIBS ${OPENSSL_LIBS} pthread) | 284 | set(OPENSSL_LIBS ${OPENSSL_LIBS} pthread) |
@@ -307,7 +307,7 @@ if(NOT MSVC) | |||
307 | add_subdirectory(man) | 307 | add_subdirectory(man) |
308 | endif() | 308 | endif() |
309 | # Tests require the openssl executable and are unavailable when building shared libraries | 309 | # Tests require the openssl executable and are unavailable when building shared libraries |
310 | if(LIBRESSL_APPS AND LIBRESSL_TESTS AND NOT BUILD_SHARED_LIBS) | 310 | if(LIBRESSL_APPS AND LIBRESSL_TESTS) |
311 | add_subdirectory(tests) | 311 | add_subdirectory(tests) |
312 | endif() | 312 | endif() |
313 | 313 | ||