aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorkinichiro <kinichiro.inoguchi@gmail.com>2016-10-18 17:13:56 +0900
committerBrent Cook <bcook@openbsd.org>2016-10-30 21:40:24 -0500
commit14905877a0eb85ebdc16162e820cda51f0895fc7 (patch)
treec8999f2188004e581e49480496139c7a5a9f7076 /CMakeLists.txt
parentb434123987dc08fd47bd988bd3fe09277445001d (diff)
downloadportable-14905877a0eb85ebdc16162e820cda51f0895fc7.tar.gz
portable-14905877a0eb85ebdc16162e820cda51f0895fc7.tar.bz2
portable-14905877a0eb85ebdc16162e820cda51f0895fc7.zip
Enable tests on Visual Studio
- add patch for aeadtest.c to undef IN - add patch for ocsp_test.c to call BIO_sock_init() before getaddrinfo() - define STDERR_FILENO in unistd.h to build pkcs7test.c - add option ENABLE_VSTEST(default OFF) to enable test on Visual Studio - modify to pass test data file as an argument (aeadtest, evptest) - add Windows scripts (ocsptest, pq_test, ssltest, testdsa, testenc, testrsa) - do not build pidwraptest on MSVC - fix some indentations
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd2ef7b..93f3ff6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,7 @@ string(REGEX REPLACE "\\..*" "" TLS_MAJOR_VERSION ${TLS_VERSION})
26option(ENABLE_ASM "Enable assembly" ON) 26option(ENABLE_ASM "Enable assembly" ON)
27option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF) 27option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF)
28option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF) 28option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF)
29option(ENABLE_VSTEST "Enable test on Visual Studio" OFF)
29set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE) 30set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE)
30 31
31set(BUILD_NC true) 32set(BUILD_NC true)
@@ -294,6 +295,8 @@ add_subdirectory(tls)
294add_subdirectory(include) 295add_subdirectory(include)
295if(NOT MSVC) 296if(NOT MSVC)
296 add_subdirectory(man) 297 add_subdirectory(man)
298endif()
299if(NOT MSVC OR ENABLE_VSTEST)
297 add_subdirectory(tests) 300 add_subdirectory(tests)
298endif() 301endif()
299 302