diff options
author | kinichiro <kinichiro.inoguchi@gmail.com> | 2016-10-18 17:13:56 +0900 |
---|---|---|
committer | Brent Cook <bcook@openbsd.org> | 2016-10-30 21:40:24 -0500 |
commit | 14905877a0eb85ebdc16162e820cda51f0895fc7 (patch) | |
tree | c8999f2188004e581e49480496139c7a5a9f7076 /CMakeLists.txt | |
parent | b434123987dc08fd47bd988bd3fe09277445001d (diff) | |
download | portable-14905877a0eb85ebdc16162e820cda51f0895fc7.tar.gz portable-14905877a0eb85ebdc16162e820cda51f0895fc7.tar.bz2 portable-14905877a0eb85ebdc16162e820cda51f0895fc7.zip |
Enable tests on Visual Studio
- add patch for aeadtest.c to undef IN
- add patch for ocsp_test.c to call BIO_sock_init() before getaddrinfo()
- define STDERR_FILENO in unistd.h to build pkcs7test.c
- add option ENABLE_VSTEST(default OFF) to enable test on Visual Studio
- modify to pass test data file as an argument (aeadtest, evptest)
- add Windows scripts (ocsptest, pq_test, ssltest, testdsa, testenc, testrsa)
- do not build pidwraptest on MSVC
- fix some indentations
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index fd2ef7b..93f3ff6 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -26,6 +26,7 @@ string(REGEX REPLACE "\\..*" "" TLS_MAJOR_VERSION ${TLS_VERSION}) | |||
26 | option(ENABLE_ASM "Enable assembly" ON) | 26 | option(ENABLE_ASM "Enable assembly" ON) |
27 | option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF) | 27 | option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF) |
28 | option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF) | 28 | option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF) |
29 | option(ENABLE_VSTEST "Enable test on Visual Studio" OFF) | ||
29 | set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE) | 30 | set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE) |
30 | 31 | ||
31 | set(BUILD_NC true) | 32 | set(BUILD_NC true) |
@@ -294,6 +295,8 @@ add_subdirectory(tls) | |||
294 | add_subdirectory(include) | 295 | add_subdirectory(include) |
295 | if(NOT MSVC) | 296 | if(NOT MSVC) |
296 | add_subdirectory(man) | 297 | add_subdirectory(man) |
298 | endif() | ||
299 | if(NOT MSVC OR ENABLE_VSTEST) | ||
297 | add_subdirectory(tests) | 300 | add_subdirectory(tests) |
298 | endif() | 301 | endif() |
299 | 302 | ||