diff options
author | Don <don.j.olmstead@gmail.com> | 2018-03-16 14:59:53 -0700 |
---|---|---|
committer | Don <don.j.olmstead@gmail.com> | 2018-03-16 14:59:53 -0700 |
commit | 09590953d05672f62a1f95913e6149f490dced80 (patch) | |
tree | 976726f1462fc9ce924c96d98f636976be109f9a /CMakeLists.txt | |
parent | 639a6629ae4b2243d1d15670f90750c3200ff4bf (diff) | |
download | portable-09590953d05672f62a1f95913e6149f490dced80.tar.gz portable-09590953d05672f62a1f95913e6149f490dced80.tar.bz2 portable-09590953d05672f62a1f95913e6149f490dced80.zip |
Remove CMAKE_HOST_ references
CMAKE_HOST_ describes the host system not the target. For cross compilation to work the actual target system should be used for making decisions in CMake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index df92e6a..df20441 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -279,7 +279,7 @@ else() | |||
279 | set(OPENSSL_LIBS tls ssl crypto) | 279 | set(OPENSSL_LIBS tls ssl crypto) |
280 | endif() | 280 | endif() |
281 | 281 | ||
282 | if(CMAKE_HOST_WIN32) | 282 | if(WIN32) |
283 | set(OPENSSL_LIBS ${OPENSSL_LIBS} ws2_32) | 283 | set(OPENSSL_LIBS ${OPENSSL_LIBS} ws2_32) |
284 | endif() | 284 | endif() |
285 | if(CMAKE_SYSTEM_NAME MATCHES "Linux") | 285 | if(CMAKE_SYSTEM_NAME MATCHES "Linux") |