diff options
author | tux3 <barrdetwix@gmail.com> | 2018-12-14 14:38:35 +0100 |
---|---|---|
committer | tux3 <barrdetwix@gmail.com> | 2018-12-14 14:38:35 +0100 |
commit | 8fee85b01338dd9bca10beeb5e7a827e241a8fe5 (patch) | |
tree | 27a118c009a1806e1258ad72fed292a60e64417c /CMakeLists.txt | |
parent | 68b54c324e9b8ff429b341268ed8b558ea1f4038 (diff) | |
download | portable-8fee85b01338dd9bca10beeb5e7a827e241a8fe5.tar.gz portable-8fee85b01338dd9bca10beeb5e7a827e241a8fe5.tar.bz2 portable-8fee85b01338dd9bca10beeb5e7a827e241a8fe5.zip |
Fix CMake not finding getpagesize for Android 19
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 4779087..9fe5837 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,5 +1,6 @@ | |||
1 | cmake_minimum_required (VERSION 2.8.8) | 1 | cmake_minimum_required (VERSION 3.0) |
2 | include(CheckFunctionExists) | 2 | include(CheckFunctionExists) |
3 | include(CheckSymbolExists) | ||
3 | include(CheckLibraryExists) | 4 | include(CheckLibraryExists) |
4 | include(CheckIncludeFiles) | 5 | include(CheckIncludeFiles) |
5 | include(CheckTypeSize) | 6 | include(CheckTypeSize) |
@@ -231,7 +232,7 @@ if(HAVE_GETENTROPY) | |||
231 | add_definitions(-DHAVE_GETENTROPY) | 232 | add_definitions(-DHAVE_GETENTROPY) |
232 | endif() | 233 | endif() |
233 | 234 | ||
234 | check_function_exists(getpagesize HAVE_GETPAGESIZE) | 235 | check_symbol_exists(getpagesize unistd.h HAVE_GETPAGESIZE) |
235 | if(HAVE_GETPAGESIZE) | 236 | if(HAVE_GETPAGESIZE) |
236 | add_definitions(-DHAVE_GETPAGESIZE) | 237 | add_definitions(-DHAVE_GETPAGESIZE) |
237 | endif() | 238 | endif() |