aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authortux3 <barrdetwix@gmail.com>2018-12-14 14:38:35 +0100
committertux3 <barrdetwix@gmail.com>2018-12-14 14:38:35 +0100
commit8fee85b01338dd9bca10beeb5e7a827e241a8fe5 (patch)
tree27a118c009a1806e1258ad72fed292a60e64417c /CMakeLists.txt
parent68b54c324e9b8ff429b341268ed8b558ea1f4038 (diff)
downloadportable-8fee85b01338dd9bca10beeb5e7a827e241a8fe5.tar.gz
portable-8fee85b01338dd9bca10beeb5e7a827e241a8fe5.tar.bz2
portable-8fee85b01338dd9bca10beeb5e7a827e241a8fe5.zip
Fix CMake not finding getpagesize for Android 19
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4779087..9fe5837 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,6 @@
1cmake_minimum_required (VERSION 2.8.8) 1cmake_minimum_required (VERSION 3.0)
2include(CheckFunctionExists) 2include(CheckFunctionExists)
3include(CheckSymbolExists)
3include(CheckLibraryExists) 4include(CheckLibraryExists)
4include(CheckIncludeFiles) 5include(CheckIncludeFiles)
5include(CheckTypeSize) 6include(CheckTypeSize)
@@ -231,7 +232,7 @@ if(HAVE_GETENTROPY)
231 add_definitions(-DHAVE_GETENTROPY) 232 add_definitions(-DHAVE_GETENTROPY)
232endif() 233endif()
233 234
234check_function_exists(getpagesize HAVE_GETPAGESIZE) 235check_symbol_exists(getpagesize unistd.h HAVE_GETPAGESIZE)
235if(HAVE_GETPAGESIZE) 236if(HAVE_GETPAGESIZE)
236 add_definitions(-DHAVE_GETPAGESIZE) 237 add_definitions(-DHAVE_GETPAGESIZE)
237endif() 238endif()