aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorkinichiro <kinichiro.inoguchi@gmail.com>2018-03-13 23:13:39 +0900
committerkinichiro <kinichiro.inoguchi@gmail.com>2018-03-13 23:16:10 +0900
commit0ed618095d6f3ea72d533079788b09ee938a3332 (patch)
tree092d303af5f86dd1e3c400b7d2e4f38f0aba7323 /CMakeLists.txt
parentc0bf25d4d1dbd14dd6286238de7d8e635d2f78bf (diff)
downloadportable-0ed618095d6f3ea72d533079788b09ee938a3332.tar.gz
portable-0ed618095d6f3ea72d533079788b09ee938a3332.tar.bz2
portable-0ed618095d6f3ea72d533079788b09ee938a3332.zip
Add libpthread for libtls build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f7c6a1..fd755ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -292,6 +292,7 @@ if(CMAKE_SYSTEM_NAME MATCHES "Linux")
292 if (HAVE_CLOCK_GETTIME) 292 if (HAVE_CLOCK_GETTIME)
293 set(OPENSSL_LIBS ${OPENSSL_LIBS} rt) 293 set(OPENSSL_LIBS ${OPENSSL_LIBS} rt)
294 endif() 294 endif()
295 set(OPENSSL_LIBS ${OPENSSL_LIBS} pthread)
295endif() 296endif()
296if(CMAKE_SYSTEM_NAME MATCHES "HP-UX") 297if(CMAKE_SYSTEM_NAME MATCHES "HP-UX")
297 set(OPENSSL_LIBS ${OPENSSL_LIBS} pthread) 298 set(OPENSSL_LIBS ${OPENSSL_LIBS} pthread)