aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDon <don.j.olmstead@gmail.com>2018-03-21 11:33:38 -0700
committerDon <don.j.olmstead@gmail.com>2018-03-21 11:33:38 -0700
commit4d753badc09cca1a85c4fb7f404bae2d6ed51f5f (patch)
treef733fb88780823f3f9e6b119bcf3648cf90a7f02 /CMakeLists.txt
parenta1c22d93cdb0dab8f1df470d6c05fda239b9054e (diff)
downloadportable-4d753badc09cca1a85c4fb7f404bae2d6ed51f5f.tar.gz
portable-4d753badc09cca1a85c4fb7f404bae2d6ed51f5f.tar.bz2
portable-4d753badc09cca1a85c4fb7f404bae2d6ed51f5f.zip
Cleanup options around tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b708f07..2873f12 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,10 +29,10 @@ string(REGEX REPLACE "\\..*" "" TLS_MAJOR_VERSION ${TLS_VERSION})
29 29
30option(LIBRESSL_SKIP_INSTALL "Skip installation" ${LIBRESSL_SKIP_INSTALL}) 30option(LIBRESSL_SKIP_INSTALL "Skip installation" ${LIBRESSL_SKIP_INSTALL})
31option(LIBRESSL_APPS "Build apps" ON) 31option(LIBRESSL_APPS "Build apps" ON)
32option(LIBRESSL_TESTS "Build tests" ON)
32option(ENABLE_ASM "Enable assembly" ON) 33option(ENABLE_ASM "Enable assembly" ON)
33option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF) 34option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF)
34option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF) 35option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF)
35option(ENABLE_VSTEST "Enable test on Visual Studio" OFF)
36set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE) 36set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE)
37 37
38if(NOT LIBRESSL_SKIP_INSTALL) 38if(NOT LIBRESSL_SKIP_INSTALL)
@@ -300,7 +300,8 @@ add_subdirectory(include)
300if(NOT MSVC) 300if(NOT MSVC)
301 add_subdirectory(man) 301 add_subdirectory(man)
302endif() 302endif()
303if(NOT MSVC OR ENABLE_VSTEST) 303# Tests require the openssl executable and are unavailable when building shared libraries
304if(LIBRESSL_APPS AND LIBRESSL_TESTS AND NOT BUILD_SHARED_LIBS)
304 add_subdirectory(tests) 305 add_subdirectory(tests)
305endif() 306endif()
306 307