diff options
author | Don <don.j.olmstead@gmail.com> | 2018-03-21 11:33:38 -0700 |
---|---|---|
committer | Don <don.j.olmstead@gmail.com> | 2018-03-21 11:33:38 -0700 |
commit | 4d753badc09cca1a85c4fb7f404bae2d6ed51f5f (patch) | |
tree | f733fb88780823f3f9e6b119bcf3648cf90a7f02 /CMakeLists.txt | |
parent | a1c22d93cdb0dab8f1df470d6c05fda239b9054e (diff) | |
download | portable-4d753badc09cca1a85c4fb7f404bae2d6ed51f5f.tar.gz portable-4d753badc09cca1a85c4fb7f404bae2d6ed51f5f.tar.bz2 portable-4d753badc09cca1a85c4fb7f404bae2d6ed51f5f.zip |
Cleanup options around tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index b708f07..2873f12 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -29,10 +29,10 @@ string(REGEX REPLACE "\\..*" "" TLS_MAJOR_VERSION ${TLS_VERSION}) | |||
29 | 29 | ||
30 | option(LIBRESSL_SKIP_INSTALL "Skip installation" ${LIBRESSL_SKIP_INSTALL}) | 30 | option(LIBRESSL_SKIP_INSTALL "Skip installation" ${LIBRESSL_SKIP_INSTALL}) |
31 | option(LIBRESSL_APPS "Build apps" ON) | 31 | option(LIBRESSL_APPS "Build apps" ON) |
32 | option(LIBRESSL_TESTS "Build tests" ON) | ||
32 | option(ENABLE_ASM "Enable assembly" ON) | 33 | option(ENABLE_ASM "Enable assembly" ON) |
33 | option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF) | 34 | option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF) |
34 | option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF) | 35 | option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF) |
35 | option(ENABLE_VSTEST "Enable test on Visual Studio" OFF) | ||
36 | set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE) | 36 | set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE) |
37 | 37 | ||
38 | if(NOT LIBRESSL_SKIP_INSTALL) | 38 | if(NOT LIBRESSL_SKIP_INSTALL) |
@@ -300,7 +300,8 @@ add_subdirectory(include) | |||
300 | if(NOT MSVC) | 300 | if(NOT MSVC) |
301 | add_subdirectory(man) | 301 | add_subdirectory(man) |
302 | endif() | 302 | endif() |
303 | if(NOT MSVC OR ENABLE_VSTEST) | 303 | # Tests require the openssl executable and are unavailable when building shared libraries |
304 | if(LIBRESSL_APPS AND LIBRESSL_TESTS AND NOT BUILD_SHARED_LIBS) | ||
304 | add_subdirectory(tests) | 305 | add_subdirectory(tests) |
305 | endif() | 306 | endif() |
306 | 307 | ||