aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDon <don.j.olmstead@gmail.com>2018-03-16 14:08:36 -0700
committerDon <don.j.olmstead@gmail.com>2018-03-16 14:08:36 -0700
commitaa60dd89f44b943a85df353b9f5be3521241a1b3 (patch)
tree92e6d22da844928c7d87b64e34be2139f22614d7 /CMakeLists.txt
parent639a6629ae4b2243d1d15670f90750c3200ff4bf (diff)
downloadportable-aa60dd89f44b943a85df353b9f5be3521241a1b3.tar.gz
portable-aa60dd89f44b943a85df353b9f5be3521241a1b3.tar.bz2
portable-aa60dd89f44b943a85df353b9f5be3521241a1b3.zip
Conditionally build apps
Add an option to build or not build the apps directory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df92e6a..7e13ed7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,7 @@ string(REPLACE ":" "." TLS_VERSION ${TLS_VERSION})
28string(REGEX REPLACE "\\..*" "" TLS_MAJOR_VERSION ${TLS_VERSION}) 28string(REGEX REPLACE "\\..*" "" TLS_MAJOR_VERSION ${TLS_VERSION})
29 29
30option(LIBRESSL_SKIP_INSTALL "Skip installation" ${LIBRESSL_SKIP_INSTALL}) 30option(LIBRESSL_SKIP_INSTALL "Skip installation" ${LIBRESSL_SKIP_INSTALL})
31option(LIBRESSL_APPS "Build apps" ON)
31option(ENABLE_ASM "Enable assembly" ON) 32option(ENABLE_ASM "Enable assembly" ON)
32option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF) 33option(ENABLE_EXTRATESTS "Enable extra tests that may be unreliable on some platforms" OFF)
33option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF) 34option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF)
@@ -307,7 +308,9 @@ add_definitions(-DSIZEOF_TIME_T=${SIZEOF_TIME_T})
307 308
308add_subdirectory(crypto) 309add_subdirectory(crypto)
309add_subdirectory(ssl) 310add_subdirectory(ssl)
310add_subdirectory(apps) 311if(LIBRESSL_APPS)
312 add_subdirectory(apps)
313endif()
311add_subdirectory(tls) 314add_subdirectory(tls)
312add_subdirectory(include) 315add_subdirectory(include)
313if(NOT MSVC) 316if(NOT MSVC)