aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <bcook@openbsd.org>2016-07-31 17:10:39 -0500
committerBrent Cook <bcook@openbsd.org>2016-07-31 17:10:39 -0500
commit1fde1eaa44153cf57de74dbe7e12d17c015863dc (patch)
treea020cb02356d846a7eba2174f38bd37fd5de23ef /CMakeLists.txt
parent1b10e48a1f0f6a4b51d0e9e1a6cd6820d3475fd5 (diff)
downloadportable-1fde1eaa44153cf57de74dbe7e12d17c015863dc.tar.gz
portable-1fde1eaa44153cf57de74dbe7e12d17c015863dc.tar.bz2
portable-1fde1eaa44153cf57de74dbe7e12d17c015863dc.zip
properly enable strnlen checks for MSVC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c38017..f0e074a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -144,7 +144,7 @@ if(HAVE_STRNDUP)
144endif() 144endif()
145 145
146if(MSVC) 146if(MSVC)
147 set(HAVE_STRNLEN) 147 set(HAVE_STRNLEN true)
148 add_definitions(-DHAVE_STRNLEN) 148 add_definitions(-DHAVE_STRNLEN)
149else() 149else()
150 check_function_exists(strnlen HAVE_STRNLEN) 150 check_function_exists(strnlen HAVE_STRNLEN)