diff options
author | Brent Cook <busterb@gmail.com> | 2018-03-14 07:29:04 -0500 |
---|---|---|
committer | Brent Cook <busterb@gmail.com> | 2018-03-14 07:29:04 -0500 |
commit | 3fb9e63b907186c70fb79e818d899ccb67b4b421 (patch) | |
tree | 6d1bd111880dff4838796915a68076339c37cbc3 /CMakeLists.txt | |
parent | b7397ab184d303b7cd6a41eaf121e47834c5b707 (diff) | |
download | portable-3fb9e63b907186c70fb79e818d899ccb67b4b421.tar.gz portable-3fb9e63b907186c70fb79e818d899ccb67b4b421.tar.bz2 portable-3fb9e63b907186c70fb79e818d899ccb67b4b421.zip |
bump base requirement to Windows Vista, use builtin inet_ntop/pton
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 7 |
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index fd755ba..df92e6a 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -98,7 +98,7 @@ if(WIN32) | |||
98 | add_definitions(-D_CRT_SECURE_NO_WARNINGS) | 98 | add_definitions(-D_CRT_SECURE_NO_WARNINGS) |
99 | add_definitions(-D_CRT_DEPRECATED_NO_WARNINGS) | 99 | add_definitions(-D_CRT_DEPRECATED_NO_WARNINGS) |
100 | add_definitions(-D_REENTRANT -D_POSIX_THREAD_SAFE_FUNCTIONS) | 100 | add_definitions(-D_REENTRANT -D_POSIX_THREAD_SAFE_FUNCTIONS) |
101 | add_definitions(-DWIN32_LEAN_AND_MEAN -D_WIN32_WINNT=0x0501) | 101 | add_definitions(-DWIN32_LEAN_AND_MEAN -D_WIN32_WINNT=0x0600) |
102 | add_definitions(-DCPPFLAGS -DOPENSSL_NO_SPEED -DNO_SYSLOG -DNO_CRYPT) | 102 | add_definitions(-DCPPFLAGS -DOPENSSL_NO_SPEED -DNO_SYSLOG -DNO_CRYPT) |
103 | endif() | 103 | endif() |
104 | 104 | ||
@@ -154,11 +154,6 @@ if(HAVE_ASPRINTF) | |||
154 | add_definitions(-DHAVE_ASPRINTF) | 154 | add_definitions(-DHAVE_ASPRINTF) |
155 | endif() | 155 | endif() |
156 | 156 | ||
157 | check_function_exists(inet_pton HAVE_INET_PTON) | ||
158 | if(HAVE_INET_PTON) | ||
159 | add_definitions(-DHAVE_INET_PTON) | ||
160 | endif() | ||
161 | |||
162 | check_function_exists(reallocarray HAVE_REALLOCARRAY) | 157 | check_function_exists(reallocarray HAVE_REALLOCARRAY) |
163 | if(HAVE_REALLOCARRAY) | 158 | if(HAVE_REALLOCARRAY) |
164 | add_definitions(-DHAVE_REALLOCARRAY) | 159 | add_definitions(-DHAVE_REALLOCARRAY) |