aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authord3x0r <d3x0r@users.noreply.github.com>2017-07-06 01:49:43 -0700
committerd3x0r <d3x0r@users.noreply.github.com>2017-07-06 01:49:43 -0700
commita2bd5ebaba789822ae73e9059171c46ed6b8f574 (patch)
treea201fa8fa7a16438b7967121724c1f0367a8d6e2 /CMakeLists.txt
parent728bda183018cbc9736f03d4f21d2b4a2585e83d (diff)
downloadportable-a2bd5ebaba789822ae73e9059171c46ed6b8f574.tar.gz
portable-a2bd5ebaba789822ae73e9059171c46ed6b8f574.tar.bz2
portable-a2bd5ebaba789822ae73e9059171c46ed6b8f574.zip
use GNUInstallDirs from cmake to specify install paths.
Primarily this is to select whether 'lib64' or 'lib' is used on linux type systems.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 570e0ef..dfb3d53 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,7 @@ include(CheckTypeSize)
6 6
7set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}" ${CMAKE_MODULE_PATH}) 7set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}" ${CMAKE_MODULE_PATH})
8include(cmake_export_symbol) 8include(cmake_export_symbol)
9include(GNUInstallDirs)
9 10
10project (LibreSSL C) 11project (LibreSSL C)
11 12