diff options
author | Brent Cook <bcook@openbsd.org> | 2017-08-13 09:53:59 -0500 |
---|---|---|
committer | Brent Cook <bcook@openbsd.org> | 2017-08-13 11:49:04 -0500 |
commit | e0cffc6b4817a3325dfb4391c458d83436f96c7b (patch) | |
tree | 7ae4adba04c874e7d76844ace06bb6ae30a64347 /CMakeLists.txt | |
parent | 8f255707f0509f403152fdc3d3a29ac6f4b3ded0 (diff) | |
download | portable-e0cffc6b4817a3325dfb4391c458d83436f96c7b.tar.gz portable-e0cffc6b4817a3325dfb4391c458d83436f96c7b.tar.bz2 portable-e0cffc6b4817a3325dfb4391c458d83436f96c7b.zip |
disable signed/unsigned mismatch in vs builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 6 |
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 959edb7..4462a79 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -109,14 +109,20 @@ if(MSVC) | |||
109 | set(MSVC_DISABLED_WARNINGS_LIST | 109 | set(MSVC_DISABLED_WARNINGS_LIST |
110 | "C4057" # C4057: 'initializing' : 'unsigned char *' differs in | 110 | "C4057" # C4057: 'initializing' : 'unsigned char *' differs in |
111 | # indirection to slightly different base types from 'char [2]' | 111 | # indirection to slightly different base types from 'char [2]' |
112 | "C4018" # '>=': signed/unsigned mismatch | ||
112 | "C4100" # 'exarg' : unreferenced formal parameter | 113 | "C4100" # 'exarg' : unreferenced formal parameter |
113 | "C4127" # conditional expression is constant | 114 | "C4127" # conditional expression is constant |
115 | "C4146" # unary minus operator applied to unsigned | ||
116 | # type, result still unsigned | ||
114 | "C4242" # 'function' : conversion from 'int' to 'uint8_t', | 117 | "C4242" # 'function' : conversion from 'int' to 'uint8_t', |
115 | # possible loss of data | 118 | # possible loss of data |
116 | "C4244" # 'function' : conversion from 'int' to 'uint8_t', | 119 | "C4244" # 'function' : conversion from 'int' to 'uint8_t', |
117 | # possible loss of data | 120 | # possible loss of data |
121 | "C4245" # 'initializing': conversion from 'long' to | ||
122 | # 'unsigned long', signed/unsigned mismatch | ||
118 | "C4267" # conversion from 'size_t' to 'some type that is almost | 123 | "C4267" # conversion from 'size_t' to 'some type that is almost |
119 | # certainly safe to convert a size_t to'. | 124 | # certainly safe to convert a size_t to'. |
125 | "C4389" # '!=': signed/unsigned mismatch | ||
120 | "C4706" # assignment within conditional expression | 126 | "C4706" # assignment within conditional expression |
121 | "C4820" # 'bytes' bytes padding added after construct 'member_name' | 127 | "C4820" # 'bytes' bytes padding added after construct 'member_name' |
122 | "C4996" # 'read': The POSIX name for this item is deprecated. Instead, | 128 | "C4996" # 'read': The POSIX name for this item is deprecated. Instead, |