aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorkinichiro <kinichiro.inoguchi@gmail>2016-04-15 14:24:00 +0900
committerkinichiro <kinichiro.inoguchi@gmail>2016-04-15 14:24:00 +0900
commit49eabdcb1619ea691e2b6d78ffb82ce60e47d20f (patch)
treef1f060cdfccb32ab7f45ce1663082950e9f0d082 /CMakeLists.txt
parent08089a1b20a1818538670d641242266ed3185814 (diff)
downloadportable-49eabdcb1619ea691e2b6d78ffb82ce60e47d20f.tar.gz
portable-49eabdcb1619ea691e2b6d78ffb82ce60e47d20f.tar.bz2
portable-49eabdcb1619ea691e2b6d78ffb82ce60e47d20f.zip
organize enabling asm condition in cmake
- add amd64 as same as x86_64 - add solaris(i386)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 447c3f3..9639f89 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -189,12 +189,16 @@ if(HAVE_ERR_H)
189 add_definitions(-DHAVE_ERR_H) 189 add_definitions(-DHAVE_ERR_H)
190endif() 190endif()
191 191
192if("${CMAKE_C_COMPILER_ABI}" STREQUAL "ELF" AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64" AND ENABLE_ASM) 192if(ENABLE_ASM)
193 set(HOST_ASM_ELF_X86_64 true) 193 if("${CMAKE_C_COMPILER_ABI}" STREQUAL "ELF")
194endif() 194 if("${CMAKE_SYSTEM_PROCESSOR}" MATCHES "(x86_64|amd64)")
195 195 set(HOST_ASM_ELF_X86_64 true)
196if(APPLE AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64" AND ENABLE_ASM) 196 elseif(CMAKE_SYSTEM_NAME STREQUAL "SunOS" AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "i386")
197 set(HOST_ASM_MACOSX_X86_64 true) 197 set(HOST_ASM_ELF_X86_64 true)
198 endif()
199 elseif(APPLE AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64")
200 set(HOST_ASM_MACOSX_X86_64 true)
201 endif()
198endif() 202endif()
199 203
200set(OPENSSL_LIBS ssl crypto) 204set(OPENSSL_LIBS ssl crypto)