diff options
author | Samuel Marks <807580+SamuelMarks@users.noreply.github.com> | 2020-05-23 17:16:04 +1000 |
---|---|---|
committer | Samuel Marks <807580+SamuelMarks@users.noreply.github.com> | 2020-05-23 17:16:04 +1000 |
commit | 12a400c90d4ab6b156f448f0421d04f96b65b324 (patch) | |
tree | ee163158d10f12920bdb88e14cd0cb4a0fcc7fd8 /CMakeLists.txt | |
parent | c4ec6b241bb70c334385471c2027a081e43026e6 (diff) | |
download | portable-12a400c90d4ab6b156f448f0421d04f96b65b324.tar.gz portable-12a400c90d4ab6b156f448f0421d04f96b65b324.tar.bz2 portable-12a400c90d4ab6b156f448f0421d04f96b65b324.zip |
[CMakeLists.txt] Move `project` below `cmake_minimum_required`; fix indentation in its `if`/`else` block; [tap-driver.sh] Copyright line update (was automatic with `./autogen.sh`)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 11 |
1 files changed, 6 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index a56f2e6..debaac4 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,9 +1,12 @@ | |||
1 | if(MSVC) | 1 | if(MSVC) |
2 | cmake_minimum_required (VERSION 3.16.4) | 2 | cmake_minimum_required (VERSION 3.16.4) |
3 | cmake_policy(SET CMP0091 NEW) | 3 | cmake_policy(SET CMP0091 NEW) |
4 | else() | 4 | else() |
5 | cmake_minimum_required (VERSION 3.0) | 5 | cmake_minimum_required (VERSION 3.0) |
6 | endif() | 6 | endif() |
7 | |||
8 | project (LibreSSL C ASM) | ||
9 | |||
7 | include(CheckFunctionExists) | 10 | include(CheckFunctionExists) |
8 | include(CheckSymbolExists) | 11 | include(CheckSymbolExists) |
9 | include(CheckLibraryExists) | 12 | include(CheckLibraryExists) |
@@ -14,8 +17,6 @@ set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}" ${CMAKE_MODULE_PATH}) | |||
14 | include(cmake_export_symbol) | 17 | include(cmake_export_symbol) |
15 | include(GNUInstallDirs) | 18 | include(GNUInstallDirs) |
16 | 19 | ||
17 | project (LibreSSL C ASM) | ||
18 | |||
19 | enable_testing() | 20 | enable_testing() |
20 | 21 | ||
21 | file(READ ${CMAKE_CURRENT_SOURCE_DIR}/ssl/VERSION SSL_VERSION) | 22 | file(READ ${CMAKE_CURRENT_SOURCE_DIR}/ssl/VERSION SSL_VERSION) |