aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Wegner <lemourin@google.com>2021-05-16 13:52:06 +0200
committerPaweł Wegner <pawel.wegner95@gmail.com>2021-05-18 16:39:39 +0200
commit21ab73316fe56428b28ed53a2bd020cfa6924d6c (patch)
tree445f3f8443212451c467ed0a7851a4812fa7c3dd /CMakeLists.txt
parent28e428e6843583a6cef9d6ff2b90a59a953ccefa (diff)
downloadportable-21ab73316fe56428b28ed53a2bd020cfa6924d6c.tar.gz
portable-21ab73316fe56428b28ed53a2bd020cfa6924d6c.tar.bz2
portable-21ab73316fe56428b28ed53a2bd020cfa6924d6c.zip
cmake: tweak for clang-cl
This change allows libressl to be built with clang-cl.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 838b7e8..06d9186 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,7 +113,6 @@ if (CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
113endif() 113endif()
114 114
115if(WIN32) 115if(WIN32)
116 add_definitions(-Drestrict)
117 add_definitions(-D_CRT_SECURE_NO_WARNINGS) 116 add_definitions(-D_CRT_SECURE_NO_WARNINGS)
118 add_definitions(-D_CRT_DEPRECATED_NO_WARNINGS) 117 add_definitions(-D_CRT_DEPRECATED_NO_WARNINGS)
119 add_definitions(-D_REENTRANT -D_POSIX_THREAD_SAFE_FUNCTIONS) 118 add_definitions(-D_REENTRANT -D_POSIX_THREAD_SAFE_FUNCTIONS)
@@ -125,7 +124,7 @@ endif()
125if(MSVC) 124if(MSVC)
126 add_definitions(-Dinline=__inline) 125 add_definitions(-Dinline=__inline)
127 message(STATUS "Using [${CMAKE_C_COMPILER_ID}] compiler") 126 message(STATUS "Using [${CMAKE_C_COMPILER_ID}] compiler")
128 if(CMAKE_C_COMPILER_ID MATCHES "MSVC") 127 if(CMAKE_C_COMPILER_ID MATCHES "MSVC" OR CMAKE_C_COMPILER_ID MATCHES "Clang")
129 set(MSVC_DISABLED_WARNINGS_LIST 128 set(MSVC_DISABLED_WARNINGS_LIST
130 "C4018" # 'expression' : signed/unsigned mismatch 129 "C4018" # 'expression' : signed/unsigned mismatch
131 "C4057" # 'operator' : 'identifier1' indirection to 130 "C4057" # 'operator' : 'identifier1' indirection to