aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <bcook@openbsd.org>2016-03-12 17:10:03 -0600
committerBrent Cook <bcook@openbsd.org>2016-03-12 17:10:03 -0600
commit05f3422a9b24d73a1ee728c9a68a6ce57cbc2dc9 (patch)
tree5be12c54aa9ffe6de9ccb15a8a3db8fbe0cba46d /CMakeLists.txt
parentbe3b129221b2f77b23fc3d833c0eb2c444624eb0 (diff)
downloadportable-05f3422a9b24d73a1ee728c9a68a6ce57cbc2dc9.tar.gz
portable-05f3422a9b24d73a1ee728c9a68a6ce57cbc2dc9.tar.bz2
portable-05f3422a9b24d73a1ee728c9a68a6ce57cbc2dc9.zip
fix check for strlcat
fixes #175
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4cf7ec..710d8a9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -96,7 +96,7 @@ if(HAVE_STRLCAT)
96 add_definitions(-DHAVE_STRLCAT) 96 add_definitions(-DHAVE_STRLCAT)
97endif() 97endif()
98 98
99check_function_exists(strlcat HAVE_STRLCPY) 99check_function_exists(strlcpy HAVE_STRLCPY)
100if(HAVE_STRLCPY) 100if(HAVE_STRLCPY)
101 add_definitions(-DHAVE_STRLCPY) 101 add_definitions(-DHAVE_STRLCPY)
102endif() 102endif()