aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorkinichiro <kinichiro.inoguchi@gmail.com>2017-01-17 21:27:41 +0900
committerkinichiro <kinichiro.inoguchi@gmail.com>2017-01-18 00:34:20 +0900
commit3b8cf47307c65f6adfe20e13e85e074a8e5cc044 (patch)
tree67d179a13a60379c02b4ea3a52d29dbaa8a706e3 /CMakeLists.txt
parent3b2560feb355e708a59ecfb224932810687a75ad (diff)
downloadportable-3b8cf47307c65f6adfe20e13e85e074a8e5cc044.tar.gz
portable-3b8cf47307c65f6adfe20e13e85e074a8e5cc044.tar.bz2
portable-3b8cf47307c65f6adfe20e13e85e074a8e5cc044.zip
Add export symbol support to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9cf14de..558a6f5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,9 @@ include(CheckLibraryExists)
4include(CheckIncludeFiles) 4include(CheckIncludeFiles)
5include(CheckTypeSize) 5include(CheckTypeSize)
6 6
7set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}" ${CMAKE_MODULE_PATH})
8include(cmake_export_symbol)
9
7project (LibreSSL C) 10project (LibreSSL C)
8 11
9enable_testing() 12enable_testing()