diff options
author | Brent Cook <busterb@gmail.com> | 2019-01-21 20:15:30 -0600 |
---|---|---|
committer | Brent Cook <busterb@gmail.com> | 2019-01-21 20:15:30 -0600 |
commit | 495a1b631687f6cc1a1e9fe217aa17184a1b4aff (patch) | |
tree | af1f59c84dec68d3157be0521c26b4e5f8f3744c /CMakeLists.txt | |
parent | 501d61c681bfc8a1217ffaf9a07344ed986ee68c (diff) | |
download | portable-495a1b631687f6cc1a1e9fe217aa17184a1b4aff.tar.gz portable-495a1b631687f6cc1a1e9fe217aa17184a1b4aff.tar.bz2 portable-495a1b631687f6cc1a1e9fe217aa17184a1b4aff.zip |
more masm fixes, but disable for now
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 7 |
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 3c79743..46e01ae 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -9,7 +9,7 @@ set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}" ${CMAKE_MODULE_PATH}) | |||
9 | include(cmake_export_symbol) | 9 | include(cmake_export_symbol) |
10 | include(GNUInstallDirs) | 10 | include(GNUInstallDirs) |
11 | 11 | ||
12 | project (LibreSSL C) | 12 | project (LibreSSL C ASM) |
13 | 13 | ||
14 | enable_testing() | 14 | enable_testing() |
15 | 15 | ||
@@ -273,7 +273,10 @@ if(ENABLE_ASM) | |||
273 | endif() | 273 | endif() |
274 | elseif(APPLE AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64") | 274 | elseif(APPLE AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64") |
275 | set(HOST_ASM_MACOSX_X86_64 true) | 275 | set(HOST_ASM_MACOSX_X86_64 true) |
276 | elseif(MSVC AND "${CMAKE_GENERATOR}" MATCHES "Win64") | 276 | elseif(MSVC AND "${CMAKE_GENERATOR}" MATCHES "Win64" AND FALSE) |
277 | # XXX Disabled for now, CMake's MASM support seems to either never | ||
278 | # build supply ASM or build it with the C compiler in a mode where it | ||
279 | # does not parse correctly. It might be easier to get NASM support working. | ||
277 | set(HOST_ASM_MASM_X86_64 true) | 280 | set(HOST_ASM_MASM_X86_64 true) |
278 | ENABLE_LANGUAGE(ASM_MASM) | 281 | ENABLE_LANGUAGE(ASM_MASM) |
279 | elseif(CMAKE_SYSTEM_NAME MATCHES "MINGW" AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64") | 282 | elseif(CMAKE_SYSTEM_NAME MATCHES "MINGW" AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64") |