aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <busterb@gmail.com>2020-05-01 04:34:48 -0500
committerBrent Cook <busterb@gmail.com>2020-05-01 04:34:48 -0500
commit13159a59e1d1715046e5b912d307c6e35d3b4631 (patch)
tree7492ebc36864cd6b06f6d102ee74c4b240aa654e /CMakeLists.txt
parent1c3377bac0a55e6a5e86e25556bf1635bb1c7bdb (diff)
downloadportable-13159a59e1d1715046e5b912d307c6e35d3b4631.tar.gz
portable-13159a59e1d1715046e5b912d307c6e35d3b4631.tar.bz2
portable-13159a59e1d1715046e5b912d307c6e35d3b4631.zip
make cmake version bump conditional on MSVC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb36210..31d2fba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,8 @@
1if(MSVC)
1cmake_minimum_required (VERSION 3.16.4) 2cmake_minimum_required (VERSION 3.16.4)
3else()
4cmake_minimum_required (VERSION 3.0)
5endif()
2include(CheckFunctionExists) 6include(CheckFunctionExists)
3include(CheckSymbolExists) 7include(CheckSymbolExists)
4include(CheckLibraryExists) 8include(CheckLibraryExists)
@@ -38,7 +42,7 @@ option(ENABLE_NC "Enable installing TLS-enabled nc(1)" OFF)
38set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE) 42set(OPENSSLDIR ${OPENSSLDIR} CACHE PATH "Set the default openssl directory" FORCE)
39 43
40option(USE_STATIC_MSVC_RUNTIMES "Use /MT instead of /MD in MSVC" OFF) 44option(USE_STATIC_MSVC_RUNTIMES "Use /MT instead of /MD in MSVC" OFF)
41if( USE_STATIC_MSVC_RUNTIMES ) 45if(USE_STATIC_MSVC_RUNTIMES)
42 set(CMAKE_MSVC_RUNTIME_LIBRARY "MultiThreaded$<$<CONFIG:Debug>:Debug>") 46 set(CMAKE_MSVC_RUNTIME_LIBRARY "MultiThreaded$<$<CONFIG:Debug>:Debug>")
43endif() 47endif()
44 48