diff options
author | Brent Cook <busterb@gmail.com> | 2021-11-09 07:08:46 -0600 |
---|---|---|
committer | Brent Cook <busterb@gmail.com> | 2021-11-09 07:08:46 -0600 |
commit | b3b087416cdfb8061a42a0a8e46455b9156074d0 (patch) | |
tree | b84e9bf7cce4af5899d0d684597b8acac2bea1c5 /CMakeLists.txt | |
parent | 7dae172f050a942928eff8e01c85d8e53f6ddf2c (diff) | |
parent | 6318b4ec48582ac85aaf12bc3ad5b82dbbc989d3 (diff) | |
download | portable-b3b087416cdfb8061a42a0a8e46455b9156074d0.tar.gz portable-b3b087416cdfb8061a42a0a8e46455b9156074d0.tar.bz2 portable-b3b087416cdfb8061a42a0a8e46455b9156074d0.zip |
Land #694, Add the option for Apple-style xcframework libraries
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 13 |
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 84c2a56..8338ab9 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -352,6 +352,19 @@ if(LIBRESSL_APPS AND LIBRESSL_TESTS) | |||
352 | add_subdirectory(tests) | 352 | add_subdirectory(tests) |
353 | endif() | 353 | endif() |
354 | 354 | ||
355 | if (BUILD_APPLE_XCFRAMEWORK) | ||
356 | # Create the super library from object libraries | ||
357 | add_library(LibreSSL_xcframework | ||
358 | $<TARGET_OBJECTS:crypto_obj> $<TARGET_OBJECTS:tls_obj> $<TARGET_OBJECTS:ssl_obj>) | ||
359 | set_target_properties(LibreSSL_xcframework PROPERTIES | ||
360 | OUTPUT_NAME ressl) | ||
361 | |||
362 | if(ENABLE_LIBRESSL_INSTALL) | ||
363 | install(TARGETS LibreSSL_xcframework | ||
364 | LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}) | ||
365 | endif(ENABLE_LIBRESSL_INSTALL) | ||
366 | endif(BUILD_APPLE_XCFRAMEWORK) | ||
367 | |||
355 | if(ENABLE_LIBRESSL_INSTALL) | 368 | if(ENABLE_LIBRESSL_INSTALL) |
356 | if(NOT MSVC) | 369 | if(NOT MSVC) |
357 | # Create pkgconfig files. | 370 | # Create pkgconfig files. |