aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorkinichiro <kinichiro.inoguchi@gmail.com>2020-05-09 18:46:13 +0900
committerkinichiro <kinichiro.inoguchi@gmail.com>2020-05-09 20:24:27 +0900
commit740488d89e69d026b8db0bf75b8bfe02ee464a3d (patch)
tree36f6f280fa6e51bb1c1512192da1690ca5fb4f19 /CMakeLists.txt
parent0e8011de3c2e4137019d4089bf20fb7192e1078c (diff)
downloadportable-740488d89e69d026b8db0bf75b8bfe02ee464a3d.tar.gz
portable-740488d89e69d026b8db0bf75b8bfe02ee464a3d.tar.bz2
portable-740488d89e69d026b8db0bf75b8bfe02ee464a3d.zip
Fix cmake build to enable masm with VS2019
To specify architecture Visual Studio 16 2019 requires -A option, and it is stored in variable CMAKE_GENERATOR_PLATFORM. Until Visual Studio 15 2017, architecture was indicated as part of generator string (e.g. "Visual Studio 15 2017 Win64")
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 515b3fc..a56f2e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -299,7 +299,7 @@ if(ENABLE_ASM)
299 endif() 299 endif()
300 elseif(APPLE AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64") 300 elseif(APPLE AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64")
301 set(HOST_ASM_MACOSX_X86_64 true) 301 set(HOST_ASM_MACOSX_X86_64 true)
302 elseif(MSVC AND "${CMAKE_GENERATOR}" MATCHES "Win64") 302 elseif(MSVC AND ("${CMAKE_GENERATOR}" MATCHES "Win64" OR "${CMAKE_GENERATOR_PLATFORM}" STREQUAL "x64"))
303 set(HOST_ASM_MASM_X86_64 true) 303 set(HOST_ASM_MASM_X86_64 true)
304 ENABLE_LANGUAGE(ASM_MASM) 304 ENABLE_LANGUAGE(ASM_MASM)
305 elseif(CMAKE_SYSTEM_NAME MATCHES "MINGW" AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64") 305 elseif(CMAKE_SYSTEM_NAME MATCHES "MINGW" AND "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64")