aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <busterb@gmail.com>2021-11-30 10:58:12 -0600
committerBrent Cook <busterb@gmail.com>2021-11-30 10:58:12 -0600
commit549ead1f94a2c2168cd162a331c399f5b3963803 (patch)
treedaf582d8aae094487974a7a4f6af549fa075ab2a /CMakeLists.txt
parent31724a737ab8f877c1ee03887e9acf06c7c61119 (diff)
downloadportable-549ead1f94a2c2168cd162a331c399f5b3963803.tar.gz
portable-549ead1f94a2c2168cd162a331c399f5b3963803.tar.bz2
portable-549ead1f94a2c2168cd162a331c399f5b3963803.zip
adjust cmake check to include dependencies for netinet/ip.h
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bcd17f7..b24e930 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -296,7 +296,7 @@ if(HAVE_ERR_H)
296 add_definitions(-DHAVE_ERR_H) 296 add_definitions(-DHAVE_ERR_H)
297endif() 297endif()
298 298
299check_include_files(netinet/ip.h HAVE_NETINET_IP_H) 299check_include_files("sys/types.h;arpa/inet.h;netinet/ip.h" HAVE_NETINET_IP_H)
300if(HAVE_NETINET_IP_H) 300if(HAVE_NETINET_IP_H)
301 add_definitions(-DHAVE_NETINET_IP_H) 301 add_definitions(-DHAVE_NETINET_IP_H)
302endif() 302endif()