aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <busterb@gmail.com>2019-01-31 10:00:48 -0600
committerBrent Cook <busterb@gmail.com>2019-01-31 13:56:56 -0600
commit5269dbb2792fe5baf239e13f36352142364e1581 (patch)
treea6e612ebf2c0d2afb8235fbd8b90d420bf186c9e /CMakeLists.txt
parenta6d7ea956290470254e817adb2f6a3fac9397a17 (diff)
downloadportable-5269dbb2792fe5baf239e13f36352142364e1581.tar.gz
portable-5269dbb2792fe5baf239e13f36352142364e1581.tar.bz2
portable-5269dbb2792fe5baf239e13f36352142364e1581.zip
update cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46e01ae..4d54ada 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -237,6 +237,21 @@ if(HAVE_GETPAGESIZE)
237 add_definitions(-DHAVE_GETPAGESIZE) 237 add_definitions(-DHAVE_GETPAGESIZE)
238endif() 238endif()
239 239
240check_function_exists(getprogname HAVE_GETPROGNAME)
241if(HAVE_GETPROGNAME)
242 add_definitions(-DHAVE_GETPROGNAME)
243endif()
244
245check_function_exists(syslog_r HAVE_SYSLOG_R)
246if(HAVE_SYSLOG_R)
247 add_definitions(-DHAVE_SYSLOG_R)
248endif()
249
250check_function_exists(syslog HAVE_SYSLOG)
251if(HAVE_SYSLOG)
252 add_definitions(-DHAVE_SYSLOG)
253endif()
254
240check_symbol_exists(timespecsub sys/time.h HAVE_TIMESPECSUB) 255check_symbol_exists(timespecsub sys/time.h HAVE_TIMESPECSUB)
241if(HAVE_TIMESPECSUB) 256if(HAVE_TIMESPECSUB)
242 add_definitions(-DHAVE_TIMESPECSUB) 257 add_definitions(-DHAVE_TIMESPECSUB)