aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <busterb@gmail.com>2023-07-07 04:32:20 -0500
committerBrent Cook <busterb@gmail.com>2023-07-07 04:32:20 -0500
commit51368394eb92381952051795a2cc226eba4daa52 (patch)
treeb97c1a95acd36ce6f0f222e3d3415471e725b99b /CMakeLists.txt
parent2354879274cdc24862bcf585815bc76718eb8400 (diff)
parent7463f87cf1c3b8494a604976a8f818b07747b55e (diff)
downloadportable-51368394eb92381952051795a2cc226eba4daa52.tar.gz
portable-51368394eb92381952051795a2cc226eba4daa52.tar.bz2
portable-51368394eb92381952051795a2cc226eba4daa52.zip
Land #886, add compat getopt implementation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02699d0..adfb540 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -176,6 +176,11 @@ if(HAVE_ASPRINTF)
176 add_definitions(-DHAVE_ASPRINTF) 176 add_definitions(-DHAVE_ASPRINTF)
177endif() 177endif()
178 178
179check_function_exists(getopt HAVE_GETOPT)
180if(HAVE_GETOPT)
181 add_definitions(-DHAVE_GETOPT)
182endif()
183
179check_function_exists(reallocarray HAVE_REALLOCARRAY) 184check_function_exists(reallocarray HAVE_REALLOCARRAY)
180if(HAVE_REALLOCARRAY) 185if(HAVE_REALLOCARRAY)
181 add_definitions(-DHAVE_REALLOCARRAY) 186 add_definitions(-DHAVE_REALLOCARRAY)