aboutsummaryrefslogtreecommitdiff
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Cook <bcook@openbsd.org>2015-10-18 09:28:10 -0500
committerBrent Cook <bcook@openbsd.org>2015-10-18 09:28:10 -0500
commit0197a589691274055e3a6f47a3652a6714d676bc (patch)
tree9a2c16f2cb86605522ce747c1a71bfd0c23db389 /apps/CMakeLists.txt
parentc8918dd0be1bbadfcebfc6631bd63f3b3e83befd (diff)
downloadportable-0197a589691274055e3a6f47a3652a6714d676bc.tar.gz
portable-0197a589691274055e3a6f47a3652a6714d676bc.tar.bz2
portable-0197a589691274055e3a6f47a3652a6714d676bc.zip
Windows compatibility fixes
VS2013 has trouble with relative include paths for apps/openssl, so move certhash_win/apps_win.c back to apps/openssl. gmtime_r on mingw64 fails with negative time_t, override gmtime_s fails all of the time unit tests, override SHUT_RD/WR are defined in newer mingw64 headers, check before overriding
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index 08bce42..6213aeb 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -2,7 +2,6 @@ include_directories(
2 . 2 .
3 ../include 3 ../include
4 ../include/compat 4 ../include/compat
5 ./openssl
6) 5)
7 6
8set( 7set(
@@ -63,8 +62,8 @@ if(CMAKE_HOST_UNIX)
63endif() 62endif()
64 63
65if(CMAKE_HOST_WIN32) 64if(CMAKE_HOST_WIN32)
66 set(OPENSSL_SRC ${OPENSSL_SRC} openssl/compat/apps_win.c) 65 set(OPENSSL_SRC ${OPENSSL_SRC} openssl/apps_win.c)
67 set(OPENSSL_SRC ${OPENSSL_SRC} openssl/compat/certhash_win.c) 66 set(OPENSSL_SRC ${OPENSSL_SRC} openssl/certhash_win.c)
68 set(OPENSSL_SRC ${OPENSSL_SRC} openssl/compat/poll_win.c) 67 set(OPENSSL_SRC ${OPENSSL_SRC} openssl/compat/poll_win.c)
69endif() 68endif()
70 69