diff options
author | Brent Cook <bcook@openbsd.org> | 2015-09-12 07:48:06 -0500 |
---|---|---|
committer | Brent Cook <bcook@openbsd.org> | 2015-09-12 08:08:24 -0500 |
commit | 854f4f69af9003c0c29d3838001f549beaf36936 (patch) | |
tree | 913e183b140e6a974efa7643ec217d0f6d574257 /apps/openssl/Makefile.am | |
parent | 34bfb6ecb5d178ee62b402ee344d0f6caf5cdad0 (diff) | |
download | portable-854f4f69af9003c0c29d3838001f549beaf36936.tar.gz portable-854f4f69af9003c0c29d3838001f549beaf36936.tar.bz2 portable-854f4f69af9003c0c29d3838001f549beaf36936.zip |
add 'nc' to the distribution as an example of libtls client and server
Diffstat (limited to 'apps/openssl/Makefile.am')
-rw-r--r-- | apps/openssl/Makefile.am | 116 |
1 files changed, 116 insertions, 0 deletions
diff --git a/apps/openssl/Makefile.am b/apps/openssl/Makefile.am new file mode 100644 index 0000000..9c763e1 --- /dev/null +++ b/apps/openssl/Makefile.am | |||
@@ -0,0 +1,116 @@ | |||
1 | include $(top_srcdir)/Makefile.am.common | ||
2 | |||
3 | bin_PROGRAMS = openssl | ||
4 | |||
5 | openssl_LDADD = $(PLATFORM_LDADD) $(PROG_LDADD) | ||
6 | openssl_LDADD += $(top_builddir)/ssl/libssl.la | ||
7 | openssl_LDADD += $(top_builddir)/crypto/libcrypto.la | ||
8 | |||
9 | openssl_SOURCES = apps.c | ||
10 | openssl_SOURCES += asn1pars.c | ||
11 | openssl_SOURCES += ca.c | ||
12 | openssl_SOURCES += ciphers.c | ||
13 | openssl_SOURCES += cms.c | ||
14 | openssl_SOURCES += crl.c | ||
15 | openssl_SOURCES += crl2p7.c | ||
16 | openssl_SOURCES += dgst.c | ||
17 | openssl_SOURCES += dh.c | ||
18 | openssl_SOURCES += dhparam.c | ||
19 | openssl_SOURCES += dsa.c | ||
20 | openssl_SOURCES += dsaparam.c | ||
21 | openssl_SOURCES += ec.c | ||
22 | openssl_SOURCES += ecparam.c | ||
23 | openssl_SOURCES += enc.c | ||
24 | openssl_SOURCES += errstr.c | ||
25 | openssl_SOURCES += gendh.c | ||
26 | openssl_SOURCES += gendsa.c | ||
27 | openssl_SOURCES += genpkey.c | ||
28 | openssl_SOURCES += genrsa.c | ||
29 | openssl_SOURCES += nseq.c | ||
30 | openssl_SOURCES += ocsp.c | ||
31 | openssl_SOURCES += openssl.c | ||
32 | openssl_SOURCES += passwd.c | ||
33 | openssl_SOURCES += pkcs12.c | ||
34 | openssl_SOURCES += pkcs7.c | ||
35 | openssl_SOURCES += pkcs8.c | ||
36 | openssl_SOURCES += pkey.c | ||
37 | openssl_SOURCES += pkeyparam.c | ||
38 | openssl_SOURCES += pkeyutl.c | ||
39 | openssl_SOURCES += prime.c | ||
40 | openssl_SOURCES += rand.c | ||
41 | openssl_SOURCES += req.c | ||
42 | openssl_SOURCES += rsa.c | ||
43 | openssl_SOURCES += rsautl.c | ||
44 | openssl_SOURCES += s_cb.c | ||
45 | openssl_SOURCES += s_client.c | ||
46 | openssl_SOURCES += s_server.c | ||
47 | openssl_SOURCES += s_socket.c | ||
48 | openssl_SOURCES += s_time.c | ||
49 | openssl_SOURCES += sess_id.c | ||
50 | openssl_SOURCES += smime.c | ||
51 | openssl_SOURCES += speed.c | ||
52 | openssl_SOURCES += spkac.c | ||
53 | openssl_SOURCES += ts.c | ||
54 | openssl_SOURCES += verify.c | ||
55 | openssl_SOURCES += version.c | ||
56 | openssl_SOURCES += x509.c | ||
57 | |||
58 | if BUILD_CERTHASH | ||
59 | openssl_SOURCES += certhash.c | ||
60 | else | ||
61 | openssl_SOURCES += compat/certhash_win.c | ||
62 | endif | ||
63 | |||
64 | if HOST_WIN | ||
65 | openssl_SOURCES += compat/apps_win.c | ||
66 | else | ||
67 | openssl_SOURCES += apps_posix.c | ||
68 | endif | ||
69 | |||
70 | if !HAVE_POLL | ||
71 | if HOST_WIN | ||
72 | openssl_SOURCES += compat/poll_win.c | ||
73 | endif | ||
74 | endif | ||
75 | |||
76 | if !HAVE_STRTONUM | ||
77 | openssl_SOURCES += compat/strtonum.c | ||
78 | endif | ||
79 | |||
80 | noinst_HEADERS = apps.h | ||
81 | noinst_HEADERS += progs.h | ||
82 | noinst_HEADERS += s_apps.h | ||
83 | noinst_HEADERS += testdsa.h | ||
84 | noinst_HEADERS += testrsa.h | ||
85 | noinst_HEADERS += timeouts.h | ||
86 | |||
87 | EXTRA_DIST = cert.pem | ||
88 | EXTRA_DIST += openssl.cnf | ||
89 | EXTRA_DIST += x509v3.cnf | ||
90 | |||
91 | install-exec-hook: | ||
92 | @if [ "@OPENSSLDIR@x" != "x" ]; then \ | ||
93 | OPENSSLDIR="$(DESTDIR)/@OPENSSLDIR@"; \ | ||
94 | else \ | ||
95 | OPENSSLDIR="$(DESTDIR)/$(sysconfdir)/ssl"; \ | ||
96 | fi; \ | ||
97 | mkdir -p "$$OPENSSLDIR/certs"; \ | ||
98 | for i in cert.pem openssl.cnf x509v3.cnf; do \ | ||
99 | if [ ! -f "$$OPENSSLDIR/$i" ]; then \ | ||
100 | $(INSTALL) -m 644 "$(srcdir)/$$i" "$$OPENSSLDIR/$$i"; \ | ||
101 | else \ | ||
102 | echo " $$OPENSSLDIR/$$i already exists, install will not overwrite"; \ | ||
103 | fi \ | ||
104 | done | ||
105 | |||
106 | uninstall-local: | ||
107 | @if [ "@OPENSSLDIR@x" != "x" ]; then \ | ||
108 | OPENSSLDIR="$(DESTDIR)/@OPENSSLDIR@"; \ | ||
109 | else \ | ||
110 | OPENSSLDIR="$(DESTDIR)/$(sysconfdir)/ssl"; \ | ||
111 | fi; \ | ||
112 | for i in cert.pem openssl.cnf x509v3.cnf; do \ | ||
113 | if cmp -s "$$OPENSSLDIR/$$i" "$(srcdir)/$$i"; then \ | ||
114 | rm -f "$$OPENSSLDIR/$$i"; \ | ||
115 | fi \ | ||
116 | done | ||