diff options
author | Brent Cook <busterb@gmail.com> | 2021-11-08 07:33:50 -0600 |
---|---|---|
committer | Brent Cook <busterb@gmail.com> | 2021-11-08 07:33:50 -0600 |
commit | 04ab1061f305d11ba292668e7405dd73008a2c1e (patch) | |
tree | d449e925f951ad7b1142de1538298d6ecfa08992 /crypto/CMakeLists.txt | |
parent | 0319bb7edb88f4eeb98f0a18072e0d7a3f62bb77 (diff) | |
download | portable-04ab1061f305d11ba292668e7405dd73008a2c1e.tar.gz portable-04ab1061f305d11ba292668e7405dd73008a2c1e.tar.bz2 portable-04ab1061f305d11ba292668e7405dd73008a2c1e.zip |
build updates
Diffstat (limited to 'crypto/CMakeLists.txt')
-rw-r--r-- | crypto/CMakeLists.txt | 6 |
1 files changed, 6 insertions, 0 deletions
diff --git a/crypto/CMakeLists.txt b/crypto/CMakeLists.txt index b1ded85..b01afa9 100644 --- a/crypto/CMakeLists.txt +++ b/crypto/CMakeLists.txt | |||
@@ -1,3 +1,5 @@ | |||
1 | add_definitions(-DLIBRESSL_CRYPTO_INTERNAL) | ||
2 | |||
1 | if(HOST_ASM_ELF_ARMV4) | 3 | if(HOST_ASM_ELF_ARMV4) |
2 | set( | 4 | set( |
3 | ASM_ARMV4_ELF_SRC | 5 | ASM_ARMV4_ELF_SRC |
@@ -726,9 +728,11 @@ set( | |||
726 | x509/pcy_map.c | 728 | x509/pcy_map.c |
727 | x509/pcy_node.c | 729 | x509/pcy_node.c |
728 | x509/pcy_tree.c | 730 | x509/pcy_tree.c |
731 | x509/x509_addr.c | ||
729 | x509/x509_akey.c | 732 | x509/x509_akey.c |
730 | x509/x509_akeya.c | 733 | x509/x509_akeya.c |
731 | x509/x509_alt.c | 734 | x509/x509_alt.c |
735 | x509/x509_asid.c | ||
732 | x509/x509_att.c | 736 | x509/x509_att.c |
733 | x509/x509_bcons.c | 737 | x509/x509_bcons.c |
734 | x509/x509_bitst.c | 738 | x509/x509_bitst.c |
@@ -982,6 +986,7 @@ target_include_directories(crypto_obj | |||
982 | ecdsa | 986 | ecdsa |
983 | evp | 987 | evp |
984 | modes | 988 | modes |
989 | x509 | ||
985 | ../include/compat | 990 | ../include/compat |
986 | PUBLIC | 991 | PUBLIC |
987 | ../include) | 992 | ../include) |
@@ -998,6 +1003,7 @@ target_include_directories(crypto | |||
998 | ecdsa | 1003 | ecdsa |
999 | evp | 1004 | evp |
1000 | modes | 1005 | modes |
1006 | x509 | ||
1001 | ../include/compat | 1007 | ../include/compat |
1002 | PUBLIC | 1008 | PUBLIC |
1003 | ../include) | 1009 | ../include) |