diff options
author | Brent Cook <busterb@gmail.com> | 2014-07-10 22:06:10 -0500 |
---|---|---|
committer | Brent Cook <bcook@openbsd.org> | 2015-07-21 12:08:18 -0500 |
commit | 5d8a1cf7155130bd8101090d7e1d0c2f90d9b123 (patch) | |
tree | 286f7d12e3647f94bd1e6e8e180a4bf6215a0740 /include/Makefile.am | |
parent | 7a4a37cf596697ae96eeb1c555989e6d1a443187 (diff) | |
download | portable-5d8a1cf7155130bd8101090d7e1d0c2f90d9b123.tar.gz portable-5d8a1cf7155130bd8101090d7e1d0c2f90d9b123.tar.bz2 portable-5d8a1cf7155130bd8101090d7e1d0c2f90d9b123.zip |
add initial CMake and Visual Studio build support
This moves the compatibility include files from include to
include/compat so we can use the awful MS C compiler
<../include/> trick to emulate the GNU #include_next extension.
This also removes a few old compat files we do not need anymore.
Diffstat (limited to 'include/Makefile.am')
-rw-r--r-- | include/Makefile.am | 50 |
1 files changed, 27 insertions, 23 deletions
diff --git a/include/Makefile.am b/include/Makefile.am index 92ee9e7..c24d1ae 100644 --- a/include/Makefile.am +++ b/include/Makefile.am | |||
@@ -2,32 +2,36 @@ include $(top_srcdir)/Makefile.am.common | |||
2 | 2 | ||
3 | SUBDIRS = openssl | 3 | SUBDIRS = openssl |
4 | 4 | ||
5 | noinst_HEADERS = err.h | 5 | noinst_HEADERS = pqueue.h |
6 | noinst_HEADERS += netdb.h | 6 | noinst_HEADERS += compat/dirent.h |
7 | noinst_HEADERS += poll.h | 7 | noinst_HEADERS += compat/dirent_msvc.h |
8 | noinst_HEADERS += pqueue.h | 8 | noinst_HEADERS += compat/err.h |
9 | noinst_HEADERS += stdio.h | 9 | noinst_HEADERS += compat/netdb.h |
10 | noinst_HEADERS += stdlib.h | 10 | noinst_HEADERS += compat/poll.h |
11 | noinst_HEADERS += string.h | 11 | noinst_HEADERS += compat/stdio.h |
12 | noinst_HEADERS += syslog.h | 12 | noinst_HEADERS += compat/stdlib.h |
13 | noinst_HEADERS += unistd.h | 13 | noinst_HEADERS += compat/string.h |
14 | noinst_HEADERS += win32netcompat.h | 14 | noinst_HEADERS += compat/time.h |
15 | noinst_HEADERS += compat/unistd.h | ||
16 | noinst_HEADERS += compat/win32netcompat.h | ||
15 | 17 | ||
16 | noinst_HEADERS += arpa/inet.h | 18 | noinst_HEADERS += compat/arpa/inet.h |
17 | noinst_HEADERS += arpa/nameser.h | 19 | noinst_HEADERS += compat/arpa/nameser.h |
18 | 20 | ||
19 | noinst_HEADERS += machine/endian.h | 21 | noinst_HEADERS += compat/machine/endian.h |
20 | 22 | ||
21 | noinst_HEADERS += netinet/in.h | 23 | noinst_HEADERS += compat/netinet/in.h |
22 | noinst_HEADERS += netinet/tcp.h | 24 | noinst_HEADERS += compat/netinet/tcp.h |
23 | 25 | ||
24 | noinst_HEADERS += sys/cdefs.h | 26 | noinst_HEADERS += compat/sys/cdefs.h |
25 | noinst_HEADERS += sys/ioctl.h | 27 | noinst_HEADERS += compat/sys/ioctl.h |
26 | noinst_HEADERS += sys/mman.h | 28 | noinst_HEADERS += compat/sys/mman.h |
27 | noinst_HEADERS += sys/select.h | 29 | noinst_HEADERS += compat/sys/param.h |
28 | noinst_HEADERS += sys/socket.h | 30 | noinst_HEADERS += compat/sys/select.h |
29 | noinst_HEADERS += sys/times.h | 31 | noinst_HEADERS += compat/sys/stat.h |
30 | noinst_HEADERS += sys/types.h | 32 | noinst_HEADERS += compat/sys/socket.h |
31 | noinst_HEADERS += sys/uio.h | 33 | noinst_HEADERS += compat/sys/time.h |
34 | noinst_HEADERS += compat/sys/types.h | ||
35 | noinst_HEADERS += compat/sys/uio.h | ||
32 | 36 | ||
33 | include_HEADERS = tls.h | 37 | include_HEADERS = tls.h |