diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 17 |
1 files changed, 1 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac index 888ca19..3aca617 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -29,8 +29,7 @@ USER_CFLAGS="$CFLAGS" | |||
29 | AC_PROG_CC([cc gcc]) | 29 | AC_PROG_CC([cc gcc]) |
30 | AC_PROG_CC_STDC | 30 | AC_PROG_CC_STDC |
31 | AM_PROG_CC_C_O | 31 | AM_PROG_CC_C_O |
32 | AC_PROG_LIBTOOL | 32 | LT_INIT([pic-only]) |
33 | LT_INIT | ||
34 | 33 | ||
35 | CHECK_OS_OPTIONS | 34 | CHECK_OS_OPTIONS |
36 | 35 | ||
@@ -75,26 +74,12 @@ AC_ARG_ENABLE([tests], | |||
75 | [enable_tests="yes"]) | 74 | [enable_tests="yes"]) |
76 | AM_CONDITIONAL([ENABLE_TESTS], [test "x$enable_tests" = xyes]) | 75 | AM_CONDITIONAL([ENABLE_TESTS], [test "x$enable_tests" = xyes]) |
77 | 76 | ||
78 | # Add CPU-specific alignment flags | ||
79 | old_cflags=$CFLAGS | ||
80 | CFLAGS="$CFLAGS -I$srcdir/include" | ||
81 | AC_MSG_CHECKING([if BSWAP4 builds without __STRICT_ALIGNMENT]) | ||
82 | AC_TRY_COMPILE([#include "$srcdir/crypto/modes/modes_lcl.h"], | ||
83 | [int a = 0; BSWAP4(a);], | ||
84 | AC_MSG_RESULT([yes]) | ||
85 | BSWAP4=yes, | ||
86 | AC_MSG_RESULT([no]) | ||
87 | BSWAP4=no) | ||
88 | CFLAGS="$old_cflags" | ||
89 | |||
90 | AS_CASE([$host_cpu], | 77 | AS_CASE([$host_cpu], |
91 | [*sparc*], [CPPFLAGS="$CPPFLAGS -D__STRICT_ALIGNMENT"], | ||
92 | [*arm*], [host_cpu=arm], | 78 | [*arm*], [host_cpu=arm], |
93 | [*amd64*], [host_cpu=x86_64 HOSTARCH=intel], | 79 | [*amd64*], [host_cpu=x86_64 HOSTARCH=intel], |
94 | [i?86], [HOSTARCH=intel], | 80 | [i?86], [HOSTARCH=intel], |
95 | [x86_64], [HOSTARCH=intel] | 81 | [x86_64], [HOSTARCH=intel] |
96 | ) | 82 | ) |
97 | AS_IF([test "x$BSWAP4" = "xyes" -a "$host_cpu" = "arm" ],,CPPFLAGS="$CPPFLAGS -D__STRICT_ALIGNMENT") | ||
98 | AM_CONDITIONAL([HOST_CPU_IS_INTEL], [test "x$HOSTARCH" = "xintel"]) | 83 | AM_CONDITIONAL([HOST_CPU_IS_INTEL], [test "x$HOSTARCH" = "xintel"]) |
99 | 84 | ||
100 | AC_MSG_CHECKING([if .gnu.warning accepts long strings]) | 85 | AC_MSG_CHECKING([if .gnu.warning accepts long strings]) |